A - Red and Black(bfs与dfs)

点击打开链接

bfs

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
int n,m,ans;
char a[100][100];
int b[100][100];
int fx[8]={0,0,-1,1,-1,1,-1,1},fy[8]={-1,1,0,0,-1,-1,1,1};

struct tt
{
	int a,b;
};

void bfs(int x,int y)
{
	b[x][y]=1;
	queue<tt> ss;
	tt o;
	o.a=x,o.b=y;
	ss.push(o);
	while(!ss.empty())
	{
		o=ss.front();
		ss.pop();
		for(int i=0;i<8;i++)
		{
			int xx=o.a+fx[i],yy=o.b+fy[i];
			if(xx>=0&&yy>=0&&xx<=n&&yy<=m&&!b[xx][yy]&&a[xx][yy]=='@')
			{
				tt w;
				b[xx][yy]=1;
				w.a=xx,w.b=yy;
				ss.push(w);
			}
		} 
	}
}



int main()
{
	while(~scanf("%d%d",&n,&m),n)
	{
		memset(b,0,sizeof(b));
		for(int i=0;i<n;i++)
		scanf("%s",a[i]);
		ans=0;
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<m;j++)
			{
				if(!b[i][j]&&a[i][j]=='@')
				{
					ans++,bfs(i,j);
				}
			}
		}
		printf("%d\n",ans);
	}
return 0;
}


dfs

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm> 
using namespace std;
int n,m,ans;
int vis[1000][1000];
char s[100][100];
int fx[8]={0,0,-1,1,-1,1,-1,1},fy[8]={-1,1,0,0,-1,-1,1,1};
void dfs(int x,int y)
{
	vis[x][y]=1;
	for(int i=0;i<8;i++)
	{
		int xx=x+fx[i],yy=y+fy[i];
		if(xx>=0&&yy>=0&&xx<=n&&yy<=m&&!vis[xx][yy]&&s[xx][yy]=='@')
		dfs(xx,yy);
	}
}


int main()
{
	while(~scanf("%d%d",&n,&m),n)
	{
		memset(vis,0,sizeof(vis));
		for(int i=0;i<n;i++)
		{
			scanf("%s",s[i]);
		}
		ans=0;
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<m;j++)
			{
				if(!vis[i][j]&&s[i][j] == '@')
				{
					ans++,dfs(i,j);
				}
			}
		}
		printf("%d\n",ans);
    }
return 0;
}


There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13


题意:从@开始,遇到#则不能通过,计算能到达的‘.’的个数。


#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define p 100+11
int n,m,ans;
int a[p][p];
char b[p][p];
int fx[4]={0,0,-1,1},fy[4]={-1,1,0,0};

void dfs(int x,int y)
{
	a[x][y]=1;
	for(int i=0;i<4;i++)
	{
		int xx=x+fx[i],yy=y+fy[i];
		if(xx>=0&&yy>=0&&xx<m&&yy<n&&!a[xx][yy]&&b[xx][yy]!='#')
		{
			ans++;
			dfs(xx,yy);
		}
	}
}

int main()
{
	int i,j,k;
	while(~scanf("%d%d",&n,&m),n)
	{
		memset(a,0,sizeof(a));
		for(i=0;i<m;i++)
		scanf("%s",b[i]);
		ans=0;
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				if(!a[i][j]&&b[i][j]=='@')
				{
					ans++;
					dfs(i,j);
				}
			}
		}
		printf("%d\n",ans);
	} 
return 0;
}











  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值