hdu5427(BestCoder Round #54 (div.2)1001题)

A problem of sorting

Accepts: 445
Submissions: 1706
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)
Problem Description
There are many people's name and birth in a list.Your task is to print the name from young to old.(There is no pair of two has the same age.)
Input
First line contains a single integer T100 which denotes the number of test cases. For each test case, there is an positive integer n(1n100) which denotes the number of people,and next n lines,each line has a name and a birth's year(1900-2015) separated by one space. The length of name is positive and not larger than 100 .Notice name only contain letter(s),digit(s) and space(s).
Output
For each case, output n lines.
Sample Input
2
1
FancyCoder 1996
2
FancyCoder 1996
xyz111 1997
Sample Output
FancyCoder
xyz111
FancyCoder
 
   
分析:只能说很坑很坑,名字不仅中间可以有空格,开头也可由空格。
 
   
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

struct node
{
    int num;
    char name[110];
}s[110];

int cmp(node a, node b)
{
    return a.num>b.num;
}

int main ()
{
    int T,n;
    char ch[110];
    scanf ("%d",&T);
    while (T--)
    {
        scanf ("%d",&n);
        getchar();
        for (int i=0; i<n; i++)
        {
            gets(ch);
            int l=strlen(ch);
            s[i].num=(ch[l-4]-'0')*1000+(ch[l-3]-'0')*100+(ch[l-2]-'0')*10+ch[l-1]-'0';
            ch[l-5]='\0';
            strcpy(s[i].name, ch);
        }
        sort(s, s+n, cmp);
        for (int i=0; i<n; i++)
        {
            puts(s[i].name);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值