hdu 5744(2016 Multi-University Training Contest 2)

Keep On Movin

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 338    Accepted Submission(s): 245


Problem Description
Professor Zhang has kinds of characters and the quantity of the   i -th character is   ai . Professor Zhang wants to use all the characters build several palindromic strings. He also wants to maximize the length of the shortest palindromic string.

For example, there are 4 kinds of characters denoted as 'a', 'b', 'c', 'd' and the quantity of each character is   {2,3,2,2}  . Professor Zhang can build {"acdbbbdca"}, {"abbba", "cddc"}, {"aca", "bbb", "dcd"}, or {"acdbdca", "bb"}. The first is the optimal solution where the length of the shortest palindromic string is 9.

Note that a string is called palindromic if it can be read the same way in either direction.
 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integer   n   (1n105)  -- the number of kinds of characters. The second line contains   n  integers   a1,a2,...,an   (0ai104) .
 

Output
For each test case, output an integer denoting the answer.
 

Sample Input
  
  
4 4 1 1 2 4 3 2 2 2 5 1 1 1 1 1 5 1 1 2 2 3
 

Sample Output
  
  
3 6 1 3
 

Author
zimpha
 

Source


 

题意:给定n个字符的个数,然后组合成若干的回文串,求这些回文串里最小的最长.........看不明白自己慢慢捋。

分析:回文串的个数是根据字符的奇数个的个数来决定的,然后平分偶数.....好水的说....

 

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
    int T,i,j,n,m;
    scanf("%d",&T);
    while(T--)
    {
        int a=0,b=0,s=0;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&m);
            if(m%2) a++;
            s+=m;
        }
        if(!a||a==1)
        {
            printf("%d\n",s);
            continue;
        }
        b=(s-a)/a/2*2+1;
        printf("%d\n",b);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值