POJ 2299 Ultra-QuickSort (树状数组 + 离散化)

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 500010
inline int lowbit(int x)
{
	return x & (-x);
}
int a[N], c[N], s[N];
int t[N];
int n;
long long ans;
void update(int i, int value)
{
	for (; i <= n; i += lowbit(i)) c[i] += value;
}
int sum(int i)
{
	int ans = 0;
	for (; i; i -= lowbit(i)) ans += c[i];
	return ans;
}
int find(int x, int a[], int l, int r)
{
	int left = l, right = r;
	int mid = left + (right - left) / 2;
	while (left <= right)
	{
		if (a[mid] == x) break;
		if (x < a[mid]) right = mid - 1;
		else left = mid + 1;
		mid = left + (right - left) / 2;
	}
	return mid;
}
void discrete()
{
	for (int i = 1; i <= n; i++) t[i] = a[i];
	sort(t + 1, t + 1 + n);
	for (int i = 1; i <= n; i++) a[i] = find(a[i], t, 1, n);
}
int main()
{
	while (scanf("%d", &n), n)
	{
		for (int i = 1; i <= n; i++) scanf("%d", &a[i]);
		discrete();
		memset(c, 0, sizeof(c));
		ans = 0;
		for (int i = n; i; i--)
		{
			update(a[i], 1);
			ans += sum(a[i] - 1);
		}
		printf("%lld\n", ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值