HDU2199:Can you solve this equation?(基本二分)

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100; 
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

题意:

8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y [0,100]有没有解

这个函数在[0,100]上是单调递增的

代码:

   

import java.util.Scanner;

public class Main {
	static final double exp=1e-8;
	public static double cal(double x){
		return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
	}
     public static void main(String[] args) {
	    Scanner scan=new Scanner(System.in);
	    int t=scan.nextInt();
	    while(t!=0){
	    	double y=scan.nextDouble();
	    	if(cal(0)>y||cal(100)<y){
	    		System.out.println("No solution!");
	    	}
	    	else{
	    		double l=0,r=100;
	    		while(r-l>exp){
	    			 double mid=(l+r)/2;
	    			 if(cal(mid)>y){
	    				 r=mid;
	    			 }
	    			 else{
	    				 l=mid;
	    			 }
	    		}
	    		System.out.printf("%.4f",l);
	    		System.out.println();
	    	}
	    	t--;
	    }
}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ksuper&

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值