CSU-ACM2017暑假集训2-二分搜索 hdu2119 - Can you solve this equation?

题目:

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100; 
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
Sample Output
1.6152
No solution!
         

 题意:给你一个方程8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y和Y的值,问你能否在1到100的区间内求出X的值。

         思路:在1到100范围内二分即可,注意浮点数判断要用EPS.

         代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define EPS 0.0001
using namespace std;

double y;
double ans;

double f(double x)
{
    return (((((8.0*x+7.0)*x+2.0)*x+3.0)*x)+6.0-y);
}

double bs(double l,double r)
{
    while(l<r)
    {
        double mid=(l+r)/2.0;
        //printf("%.5f\n",fabs(f(mid)));
        if(fabs(f(mid))<=EPS)
            return mid;
        if(f(l)*f(mid)<=0)
            r=mid;
        else if(f(mid)*f(r)<=0)
            l=mid;
        else
            return -1;
    }
    return -1;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ans=111.0;
        scanf("%lf",&y);
        ans=bs(0.0,100.0);
        if(ans!=-1)
            printf("%.4f\n",ans);
        else
            printf("No solution!\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值