Virtual Friends (并查集+map)

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends. 

Your task is to observe the interactions on such a website and keep track of the size of each person's network. 

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.

Input

Input file contains multiple test cases. 
The first line of each case indicates the number of test friendship nest. 
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input

1
3
Fred Barney
Barney Betty
Betty Wilma

Sample Output

2
3
4

题意:  多组测试用例,求输入的两个人的朋友圈总人数

思路:并查集建立关系求人数,map标记建立关系  - ans++

代码: 

#include<iostream>
#include<algorithm>
#include<map>
using namespace std;
const int maxn=100005;
int pre[maxn];
int num[maxn];
map<string,int> m;
int find(int x)
{
	if(pre[x]==x)
	   return x;
	return pre[x]=find(pre[x]);
}
void merge(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx==fy)
	{
		printf("%d\n",num[fy]);
	}
	else
	{
		pre[fx]=fy;
		num[fy]+=num[fx];
		printf("%d\n",num[fy]);
	}
}
int main()
{
	int t,c;
	while(~scanf("%d",&t))
	{
		while(t--)
	    {
		for(int i=1;i<=maxn;i++)
		{
			pre[i]=i; 
		    num[i]=1;
		}
		scanf("%d",&c);
		int ans=1;
		string a,b;
		m.clear(); //一定要清空 
		for(int i=1;i<=c;i++) 
		{
			cin>>a>>b;
			if(!m[a])
			{
				m[a]=ans++;
			}
			if(!m[b])
			{
				m[b]=ans++;
			}
			merge(m[a],m[b]);
		}
	    }
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小鱼爱吃火锅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值