HDU 1796 How many integers can you find (容斥原理)

题目链接:How many integers can you find



题面:

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5345    Accepted Submission(s): 1515


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
  
  
12 2 2 3
 

Sample Output
  
  
7
 

Author
wangye
 

Source
 

Recommend
wangye


解题:

     容斥原理是早学过,但从没想过功能如此强大,最近老是碰到。这道题,题意是求给定的集合中,在1~(n-1)范围内,能找到多少个数,为集合中任一数的倍数。其实也就是求这些数倍数集合的并。以两个为例,根据容斥原理,结果等于集合A∪集合B-集合A∩B。A∩B,即为既是A的倍数,又是B的倍数,那么就是A,B最小公倍数的倍数。模拟二进制表示,某位取或不取,最后容斥一下,就得到结果了。神坑的是,很容易看错,是会有0出现的,需要排除掉。


代码:

#include <iostream>
#include <cstring>
using namespace std;
int one_amount[1050];
int refl[1050][10];
void cal()
{
    memset(refl,0,sizeof(refl));
    int cnt=0,temp;
   for(int i=0;i<1024;i++)
   {
       temp=i;
       one_amount[i]=cnt=0;
       while(temp)
       {
         if(temp%2)
         {
             one_amount[i]++;
             refl[i][cnt]=1;
         }
         cnt++;
         temp/=2;
       }
   }
}
long long gcd(long long a,long long b)
{
    if(a==0)return b;
    else return gcd(b%a,a);
}
int main()
{
    int m,x;
    unsigned long long n,store[12],tmp,ans,temp;
    cal();
    while(cin>>n>>m)
    {
        ans=0;
        int y=m,z=0;
       while(y--)
       {
           cin>>store[z];
           if(store[z]==0)
           {
               m--;
               continue;
           }
           else z++;
        }
       x=1;
       for(int i=0;i<m;i++)
           x*=2;
       for(int i=1;i<x;i++)
       {
            tmp=1;
            for(int j=0;j<m;j++)
            {
                if(refl[i][j])
                {
                    temp=gcd(tmp,store[j]);
                    tmp=tmp*store[j]/temp;
                }
            }
            if(one_amount[i]%2)
            ans+=(n-1)/tmp;
            else
            ans-=(n-1)/tmp;
       }
       cout<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值