HDU 5734 Acperience (观察)

题目链接:HDU 5734


题面:

Acperience

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 475    Accepted Submission(s): 251


Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,...,wn) . Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi{+1,1}) and a scaling factor α0 in such a manner that WαB2 is minimum.

Note that denotes the Euclidean norm (i.e. X=x21++x2n , where X=(x1,x2,...,xn) ).
 

Input
There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:

The first line contains an integers n (1n100000) -- the length of the vector. The next line contains n integers: w1,w2,...,wn (10000wi10000) .
 

Output
For each test case, output the minimum value of WαB2 as an irreducible fraction " p / q " where p , q are integers, q>0 .
 

Sample Input
  
  
3 4 1 2 3 4 4 2 2 2 2 5 5 6 2 3 4
 

Sample Output
  
  
5/1 0/1 10/1
 

Author
zimpha
 

Source


题意:

    已知w序列,要求你确定阿尔法和B序列的{-1,1}的取值,使得 WαB2 的值最小。


解题:

    先将最终表达式展开,假定B序列的取值已定,根据二次函数的特性,取阿尔法的值为-b/2a。代入式子,发现(sigma(bi*wi))^2的值越大,整个式子的值越小,故当wi为负时,bi取负,反之取正。


代码:

#include <iostream>
#include <cstdio>
#define LL long long
using namespace std;
int w[100005];
int abs(int x)
{
    if(x<0)return -x;
    return x;
}
LL gcd(LL a,LL b)
{
    if(a==0)return b;
    return gcd(b%a,a);
}
int main()
{
    int t,n;
    LL fenzi,fenmu,wsum,tgcd;
    scanf("%d",&t);
    while(t--)
    {
      wsum=0;
      scanf("%d",&n);
      fenmu=n;
      for(int i=1;i<=n;i++)
      {
          scanf("%d",&w[i]);
          wsum+=w[i]*w[i];
      }
      fenzi=1LL*n*wsum;
      wsum=0;
      for(int i=1;i<=n;i++)
      {
          wsum+=abs(w[i]);
      }
      wsum*=wsum;
      fenzi-=wsum;
      tgcd=gcd(fenzi,fenmu);
      printf("%lld/%lld\n",fenzi/tgcd,fenmu/tgcd);
    }    
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值