7-6 实验2_1_判断两数的大小 (100 分)

已知有两个整数,请使用if-else选择结构将它们中的较大数选择出来,存到max变量中;将较小数选择出来,存到min变量中,并将选择结果输出。

输入格式:

只有一行,为用空格分隔的两个整数。测试用例保证这两个数可以用int类型存储。

输出格式:

如果输入的两个整数相等,则输出“The two numbers are equal.”,如果不等则按如下格式输出:“The larger number is 100, the smaller number is 25.”(假设输入的两个数分别为100和25)。

输入样例:

100 25

输出样例:

The larger number is 100, the smaller number is 25.

代码如下:

#include <stdio.h>
int main()
{
    int a,b;
    scanf("%d %d",&a,&b);
       if(a == b)
           printf("The two numbers are equal.\n");
       else if(a>b)
               printf("The larger number is %d, the smaller number is %d.\n",a,b);
       else 
               printf("The larger number is %d, the smaller number is %d.\n",b,a);
    return 0;
           
}

考察基本的输入输出和if-else 的使用

if - else 即实现双路选择

 

 if else的嵌套选择

if(a==b)
    printf("a==b");
else if(a>b)
    printf("a>b);
else
    printf("a<b);

以后会介绍switch语句

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值