HDU 2199 Can you solve this equation(二分水题)


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 


Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 


Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 


Sample Input
  
  
2 100 -4
 


Sample Output
  
  
1.6152 No solution!

思路:题目中的关于x的式子是单调递增的,当<f(0) ||  >f(100)时不存在,所以可以采用二分法不断缩小范围,但要注意二分法的终止条件

#include <stdio.h>
#include <math.h>
double f(double x)
{
    return (8.0*x*x*x*x+7.0*x*x*x+2*x*x+3*x+6);
}

int main()
{
    //freopen("e:\\in.txt","r",stdin);
     int T;
     double re;
    scanf("%d",&T);
    while(T--)
    {
       scanf("%lf",&re);
       if(f(0)>re||f(100)<re)
        printf("No solution!\n");
       else
       {
           double low=0.0,high=100.0,middle=50.0;
           while(fabs(f(middle)-re)>1e-5)
           {
               if(f(middle)>re)
                  high=middle-1;
               else if(f(middle)<re)
                   low=middle+1;

                middle=(low+high)/2;
           }
           printf("%.4lf\n",middle);

       }
    }
    return 0;
}



要点:1.二分法的终止条件:fabs()<1e-5,意义为当其小于0时,(二分法的终止条件要根据题目来判断)

2.从键盘上输入的是整数,但如果它的类型是double,则实际是浮点型数字。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值