给出正整数 n 和 m,统计满足以下条件的正整数对 (a,b) 的数量:
1. 1≤a≤n,1≤b≤m;
2. a×b 是 2016 的倍数。
Input
输入包含不超过 30 组数据。
每组数据包含两个整数 n,m (1≤n,m≤10 9).
Output
对于每组数据,输出一个整数表示满足条件的数量。
Sample Input
32 63
2016 2016
1000000000 1000000000
Sample Output
1
30576
1. 1≤a≤n,1≤b≤m;
2. a×b 是 2016 的倍数。
Input
输入包含不超过 30 组数据。
每组数据包含两个整数 n,m (1≤n,m≤10 9).
Output
对于每组数据,输出一个整数表示满足条件的数量。
Sample Input
32 63
2016 2016
1000000000 1000000000
Sample Output
1
30576
7523146895502644
思路:求2016的倍数,很容易发现可以和2016取模有关系 例如1 和 2017 在这个问题中其实是相同的,而全部化成对2016的模,方便计数,然后0-2015 0-2015的循环 寻找那一组数相乘是2016的被试
正向:
#include <iostream>
#include <cstdio>
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
const int N=3e3;
ll a[N],b[N];
int main()
{
ll n,m;
while(scanf("%lld %lld",&n,&m)==2){
//计算有少个"重复"数字
for(int i=0;i<2016;i++){
a[i]=n/2016;
b[i]=m/2016;
}
for(int i=1;i<=n%2016;i++)
a[i]++;
for(int i=1;i<=m%2016;i++)
b[i]++;
ll ans=0;
for(int i=0;i<2016;i++)
for(int j=0;j<2016;j++){
if(i*j%2016==0)
ans+=a[i]*b[j];
}
printf("%lld\n",ans);
}
return 0;
}
反向:先计算哪些数字不可以,再用总的-不可以
#include<stdio.h>
typedef long long LL;
LL a[3000],b[3000];
int main()
{
LL n,m;
while(~scanf("%lld%lld",&n,&m))
{
for(LL i=0;i<=2015;++i)
{
a[i]=n/2016;
b[i]=m/2016;
}
for(LL i=1;i<=n%2016;++i)
{
++a[i];
}
for(LL i=1;i<=m%2016;++i)
{
++b[i];
}
LL ans=n*m;
for(LL i=0;i<=2015;++i)
for(LL j=0;j<=2015;++j)
{
if(i*j%2016!=0)
ans-=a[i]*b[j];
}
printf("%lld\n",ans);
}
return 0;
}