Multitasking


  Multitasking 

Calendars control our daily lives. For people like me, who are bad at multitasking, it is important to have at most one task planned for any minute of my life. Your job is to make sure that my calendar is free of conflicts for the next one million minutes (just over 99 weeks) of my life. To keep things simple, all times are expressed in minutes from a fixed time 0 representing ``now".

\epsfbox{p11926.eps}

In this calendar, there are two types of tasks: one-time tasks and repeating tasks. One-time tasks have a start time and an end time. Repeating tasks have a start time and an end time for their first occurrence, and a repetition interval. Repeating tasks are assumed to keep repeating forever without end. For example, a repeating task with start time 5, end time 8 and repetition interval 100 would be occurring at time intervals [5..8], [105..108], [205..208], ...

Tasks are considered to be in conflict if and only if their time intervals overlap, for example [2..5] and [4..6] overlap. ``Touching" is OK, for example [2..5] and [5..6] do not overlap.

Input

There are approximately 30 test cases. The first line of each test case contains two numbers n and m. n is the number of one-time tasks and m the number of repeating tasks. The following n lines contain two numbers each, the start and end times respectively of a one-time task. Afterward, m more lines similarly describe the repeating tasks by giving their start times, end times, and repetition intervals. Both n and m are at most 100.

All numbers are integers in the range [0..1000000]. For each task, the end time is guaranteed to be larger than the start time, and the repetition interval is larger than 0.

Input terminates with a line containing `0 0' which should not be processed.

Output

For each test case, print a single line containing either the words ` NO CONFLICT' if there are no overlaps between any tasks for minutes 0..1000000, or ` CONFLICT' if there is at least one overlap.

Sample Input

2 0
10 20
20 30
2 0
10 30
20 21
1 1
1000 2000
0 10 1000
0 0

Sample Output

NO CONFLICT
CONFLICT
CONFLICT

#include<stdio.h>
#include<string.h>
int z[1000007];
struct sa
{
   int start,end,res;
} data[1000007],data1[1000007];

int main()
{
    int n,m,i,j,k;
    while(scanf("%d%d",&n,&m),n|m)
    {
        memset(z,0,sizeof(z));
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&data[i].start,&data[i].end);
            for(j=data[i].start; j<data[i].end; j++)
                z[j]++;
        }
        for(i=0; i<m; i++)
        {
            scanf("%d%d%d",&data1[i].start,&data1[i].end,&data1[i].res);
            int  b=data1[i].start,e=data1[i].end,r=data1[i].res;
            while(e<=1000007)
            {
                for(j=b; j<e; j++)
                {
                    z[j]++;
                }
                b+=r;
                e+=r;
            }

        }
        int flag=0;
            for(i=0;i<1000007;i++)
            if(z[i]>1)
            {
                flag=1;
                break;
            }
            if(!flag)printf("NO CONFLICT\n");
            else printf("CONFLICT\n");

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值