HDU 5805 NanoApe Loves Sequence (模拟)

NanoApe Loves Sequence

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=5805

Description


NanoApe, the Retired Dog, has returned back to prepare for the National Higher Education Entrance Examination!
In math class, NanoApe picked up sequences once again. He wrote down a sequence with n numbers on the paper and then randomly deleted a number in the sequence. After that, he calculated the maximum absolute value of the difference of each two adjacent remained numbers, denoted as F.
Now he wants to know the expected value of F, if he deleted each number with equal probability.

Input


The first line of the input contains an integer T, denoting the number of test cases.
In each test case, the first line of the input contains an integer n, denoting the length of the original sequence.
The second line of the input contains n integers A1,A2,...,An, denoting the elements of the sequence.
1≤T≤10, 3≤n≤100000, 1≤Ai≤109

Output


For each test case, print a line with one integer, denoting the answer.
In order to prevent using float number, you should print the answer multiplied by n.

Sample Input


1
4
1 2 3 4

Sample Output


6


题意:


每次从数组中删除 Ai 并求相邻元素绝对值之差的最大值. (再把Ai放回来)
对以上最大值求和.


题解:


直接模拟,分别记录位置i左边和右边的数构成的最大值.
结果就是:i左边、i右边、与i相邻两数差 这三者的最大值.


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <vector>
#include <list>
#define LL long long
#define eps 1e-8
#define maxn 101000
#define mod 1000000007
#define inf 0x3f3f3f3f
#define mid(a,b) ((a+b)>>1)
#define IN freopen("in.txt","r",stdin);
using namespace std;

int n;
int num[maxn];
int _left[maxn];
int _right[maxn];

int main(void)
{
    //IN;

    int t; cin >> t;
    while(t--)
    {
        scanf("%d", &n);
        for(int i=1; i<=n; i++) {
            scanf("%d", &num[i]);
        }

        memset(_left, 0, sizeof(_left));
        memset(_right, 0, sizeof(_right));

        for(int i=2; i<=n; i++) {
            _left[i] = max(_left[i-1], abs(num[i]-num[i-1]));
        }

        for(int i=n-1; i>=1; i--) {
            _right[i] = max(_right[i+1], abs(num[i]-num[i+1]));
        }

        LL ans = 0;
        for(int i=1; i<=n; i++) {
            int cur = max(_left[i-1], _right[i+1]);
            if(i!=1 && i!=n) cur = max(cur, abs(num[i+1]-num[i-1]));
            ans += (LL)cur;
        }

        printf("%lld\n", ans);
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5774201.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值