1001 A+B Format

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

简单翻译:求两个数的和,将和从个位到高位,每三个数由逗号分隔,负号保留,如:-1001 -> -1,001

解析:主要是求和后转成字符串,用字符串的长度 len%3 判断一下是否等于下标 (i+1)%3,注意末尾没有逗号!

import java.util.Scanner;

public class Main{

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner input = new Scanner(System.in) ;
		int a, b ;
		
		a = input.nextInt() ;
		b = input.nextInt() ;
		
		String sum = Integer.toString(a + b) ;
		
		int i ;
		int len = sum.length() ;

		for(i=0; i<len; i++) {
			System.out.printf("%c", sum.charAt(i)) ;
			if(sum.charAt(i) == '-') continue ;
			if((i + 1) % 3 == len % 3 && i != len - 1) {
				System.out.printf(",") ;
			}
		}
		System.out.println() ;
	}

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值