PAT-A-1048. Find Coins (25)

1048. Find Coins (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution
#include<iostream>
#include<cstdio>

using namespace std;

int main()
{
  int a[1001] = { 0 };
  int n, m;
  int v;
  cin >> n >> m;

  int num;
  for (int i = 0; i < n; i++)
  {
    cin >> num;
    a[num]++;

  }

  int flag = 0;
  for (int i = 1; i < 501; i++)
  {
    if (a[i] && a[m - i])
    {
      flag = 1;
      v = i;
      break;
    }
  }

  if (v == m - v&&a[v]<2)
    flag = 0;

  if (flag)
    cout << v << " " << m - v << endl;
  else
    cout << "No Solution" << endl;


  system("pause");
  return 0;
}

这个警告是因为在 `find_fake_coin()` 函数中,我们在第一次称重时计算了第三组硬币的总重量,但是在后续的递归调用中没有使用到这个值,因此编译器提示这个变量没有被使用。 可以将第三组硬币的总重量的计算从称重部分移动到递归调用部分,这样就不会出现这个警告了。修改后的代码如下所示: ```cpp #include <iostream> #include <vector> using namespace std; // 将硬币分成三组 vector<vector<int>> split_coins(const vector<int>& coins) { int n = coins.size(); int group_size = n / 3; int left_size = n - group_size * 3; vector<vector<int>> groups; int i = 0; while (i < n) { vector<int> group; int j = 0; while (j < group_size && i < n) { group.push_back(coins[i]); i++; j++; } if (left_size > 0 && i < n) { group.push_back(coins[i]); i++; left_size--; } groups.push_back(group); } return groups; } // 称重函数,返回硬币的总重量 int weigh_coins(const vector<int>& coins) { int weight = 0; for (int coin : coins) { weight += coin; } return weight; } // 递归函数,找到假币并输出求解过程 void find_fake_coin(const vector<int>& coins, int left, int right) { if (left == right) { cout << "硬币" << left << "是假币" << endl; } else { // 将硬币分成三组 vector<vector<int>> groups = split_coins(coins); // 称重 int weight1 = weigh_coins(groups[0]); int weight2 = weigh_coins(groups[1]); if (weight1 == weight2) { // 假币在第三组 int weight3 = weigh_coins(groups[2]); cout << "硬币" << left << "-" << right - groups[2].size() << "和硬币" << right - groups[2].size() + 1 << "-" << right << "称重一次且前者重量轻" << endl; find_fake_coin(groups[2], right - groups[2].size() + 1, right); } else if (weight1 < weight2) { // 假币在第一组 cout << "硬币" << left << "-" << left + groups[0].size() - 1 << "和硬币" << right - groups[2].size() + 1 << "-" << right << "称重一次且两者重量相同" << endl; find_fake_coin(groups[0], left, left + groups[0].size() - 1); } else { // 假币在第二组 cout << "硬币" << left + groups[0].size() << "-" << right - groups[2].size() << "和硬币" << right - groups[2].size() + 1 << "-" << right << "称重一次且前者重量轻" << endl; find_fake_coin(groups[1], left + groups[0].size(), right - groups[2].size()); } } } int main() { int n, k; cin >> n >> k; // 初始化硬币编号和重量 vector<int> coins(n); for (int i = 0; i < n; i++) { coins[i] = (i + 1 == k) ? -1 : 1; // 标记假币 } // 找到假币并输出求解过程 cout << "采用三分法,且必须按的方式对硬币进行三分,否则求解过程可能与测试样例输出不一致" << endl; cout << "当天平的某一端硬币为单枚时,求解过程应仅出现单枚编号" << endl; find_fake_coin(coins, 1, n); return 0; } ``` 修改后,编译器就不会再提示这个警告了。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值