【C++】PAT(advanced level)1048. Find Coins (25)

1048. Find Coins (25)

时间限制
50 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution

1.用map做,不遍历每个coins 而是遍历coins的value的个数,遍历什么挺重要的 

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#include<map>
using namespace std;


int main(){
	//	freopen("in.txt","r",stdin);
	int N,M;
	map <int,int> cs;
	while(cin>>N){
		cin>>M;
		int n=N;
		while(n--){
			int temp;
			scanf("%d",&temp);
			cs[temp]++;
		}
		n=1;
		while(true){
			if(cs[n]>=2&&(M==n*2)){
				cout<<n<<" "<<n;
				break;
			}
			if((n<M-n)&&cs[n]>0&&cs[M-n]>0){
				cout<<n<<" "<<M-n;
				break;
			}
			if(n>=M/2){
				cout<<"No Solution";
				break;
			}	
			n++;
		}
	}
	//	fclose(stdin);
	system("pause");
	return 0;
}


aaaa1一个个遍历容易超时

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
using namespace std;

bool cmp(int a,int b){
	return a<b;
}

int main(){
	freopen("in.txt","r",stdin);
	int N,M;
	vector <int> cs;
	while(cin>>N){
		cin>>M;
		int n=N;
		while(n--){
			int temp;
			scanf("%d",&temp);
			cs.push_back(temp);
		}
		sort(cs.begin(),cs.end(),cmp);
		int m;
		bool flag=true,nos=false;
		for(n=0;n<N-1;n++){
			if(cs[n]+cs[N-1]<M){
				break;
			}
			for(m=n+1;m<N;m++){
				if(cs[n]+cs[m]==M){
					//cout<<cs[n]<<" "<<cs[m];
					printf("%d %d",cs[n],cs[m]);
				//	nos=false;
					//flag=false;
					break;
				}
				if(cs[n]+cs[m]>M){
					if(m==n+1){
						nos=true;
						flag=false;
					}
					break;
				}
			}
			if(!flag){
				break;
			}
		}
		if(nos){
			printf("No Solution");
		}
	}

	fclose(stdin);
	system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值