POJ_3061 Subsequence

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16654 Accepted: 7075

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source


翻译:

描述: N个正整数的序列(N大于10小于10 000),每个数小于或等于10000,并且给出一个正整数S(S小于100000000)。编写一个程序来查找序列中连续元素的子序列的最小长度,其总和大于或等于s。

输入:第一行是测试用例的数量。对于每一个测试用例,程序必须读取数字N和S,从第一行中分离出来。序列的数量在测试用例的第二行中给出,以间隔隔开。输入将以文件的末尾结束。

输出:对于每种情况,程序都必须在输出文件的单独行上打印结果。如果没有答案,打印0。

样例输入:

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

样例输出:

2
3


这题说白了就是求字串,串长最小,串值最大,比较经典。用两个变量循环求子串是会超时的,参考了别人的代码才知道还有更巧妙的方法
花了不少时间才AC
#include <cstdio>
int main(){
int t;
scanf("%d",&t);
while(t--){
int n,s;
scanf("%d%d",&n,&s);
int data[n];
for(int i=0;i<n;i++){
	scanf("%d",&data[i]);
}
int min=n+1;			//字串长度 
int i=0,j=1;
int sum=data[0];
while(j<n){
		while(sum<s&&j<n){
		sum+=data[j++];
		}
		while(sum>=s&&i<=j){
			sum-=data[i++];
		}
	//	printf("%d\t",sum+data[i-1]);
		if(sum+data[i-1]>=s&&min>j-i+1){
		 min=j-i+1;
	
	}
}
if(min==n+1) printf("0\n");
else printf("%d\n",min);
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值