Play On Words

Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve

it to open that doors. Because there is no other way to open the doors, the puzzle is very important
for us.
There is a large number of magnetic plates on every door. Every plate has one word written on
it. The plates must be arranged into a sequence in such a way that every word begins with the same
letter as the previous word ends. For example, the word ‘acm’ can be followed by the word ‘motorola’.
Your task is to write a computer program that will read the list of words and determine whether it
is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to
open the door.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file.
Each test case begins with a line containing a single integer number N that indicates the number of
plates (1 ≤ N ≤ 100000). Then exactly N lines follow, each containing a single word. Each word
contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will
appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that
the first letter of each word is equal to the last letter of the previous word. All the plates from the
list must be used, each exactly once. The words mentioned several times must be used that number of
times.
If there exists such an ordering of plates, your program should print the sentence ‘Ordering is
possible.’. Otherwise, output the sentence ‘The door cannot be opened.’
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.

The door cannot be opened.

这道题是有关欧拉回路的题目,所以首先介绍一下欧拉回路。

一、欧拉回路于欧拉道路

    1.欧拉回路:图G的一个回路,若它恰通过G中每条边一次,则称该回路为欧拉(Euler)回路

     2.欧拉道路:一个图只是形成一个连通所有结点的链,且每一个点只走一次。

    具有欧拉回路和欧拉道路的图统称为欧拉图(E图)

二、判断

    1.无向图:最多有两个奇点且连通。如果有奇点,则从奇点出发找到一条欧拉道路,若无奇点可从任意一点出发。

    2.有向图:连通且任意一点的入度等于出度或者一个点的入度比出度多一(即终点)、一个点的出度比入度多一(即起点)。如       果有起点和终点,就从起点出发到达终点走出一条欧拉道路,否则就从任意一点出发走出一条。

   总结一下就是,先看出度和入度,然后判断连通性(用DFS或者并查集)

这道题因为是把所有的单词按照一定的顺序排列好,可以把单词看成是结点,原题就转化成了找到一条欧拉道路。代码如下:

#include<cstdio>
#include<cstring>
using namespace std;

const int maxn=1000+5;
int d[27],start;
bool flag[27],G[27][27];

void dfs(int x)      //dfs判断连通性
{
	flag[x]=false;
	for(int i=0;i<26;i++)
	{
		if(G[x][i]&&flag[i]) dfs(i);
	}
}
bool check()   //检查出度和入度
{
	int a=0,b=0,c=0;
	for(int i=0;i<26;i++)
	{
		if(d[i]==1)
		{
			start=i;  //注意起点
			++a;
		}
		if(d[i]==-1) ++b;
		if(d[i]==0) ++c;
	}
	if(c!=26)
	{
		if((a+b+c)!=26) return false;
		if(!(a==1&&b==1)) return false;
	}
	dfs(start);
	for(int i=0;i<26;i++)
	{
		if(flag[i]) return false;
	}
	return true;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int N;
		scanf("%d",&N);
		memset(d,0,sizeof(d));memset(flag,false,sizeof(flag));memset(G,false,sizeof(G));
		for(int i=0;i<N;i++)
		{
			char s[maxn];
			int x,y,len;
			scanf("%s",s);
			len=strlen(s);
			x=s[0]-'a';y=s[len-1]-'a';
			d[x]++;d[y]--;
			start=x;
			flag[x]=true;flag[y]=true;
			G[x][y]=true;G[y][x]=true;
		}
		if(check())
			printf("Ordering is possible.\n");
		else
			printf("The door cannot be opened.\n");
	}
	return 0;
}

这里有三个数组:flag【】和G【】【】用于判断连通性,一个是把经过的点做下标记,另一个是存放两个点是否连通;d【】用于记录出度和入度

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值