PAT日志 1013

顽强的小白

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题目解析

给出一个图,规定删除图中的任意顶点同时也会删除与这个顶点相连的所有路径。
给出k次查询,问删除给定顶点后,最少还需要添加多少条边才能使图连通。

思路:
  • 所谓添加的边数最少,就是使图中所有连通分量连接起来,也就是最少边数等于连通区个数减一。

代码实现

#include <cstdio> 
#include <algorithm>
#include <vector>
using namespace std;
const int maxn=1111;
vector<int> G[maxn];
bool vis[maxn];int cut;
int n,m,k;
void DFS(int v){
 if(v==cut) return;
 vis[v]=true;
 for(int i=0;i<G[v].size();++i){
  if(vis[G[v][i]]==false){
   DFS(G[v][i]);
  }
 }
}
int main(){
 int u,v;
 scanf("%d%d%d",&n,&m,&k);
 for(int i=0;i<m;++i){
  scanf("%d%d",&u,&v);
  G[u].push_back(v);
  G[v].push_back(u);
 }
 for(int i=0;i<k;++i){
  scanf("%d",&cut);
  fill(vis,vis+maxn,false);
  int block=0;           //连通块个数
  for(int j=1;j<=n;++j){           //注意这个下标从 1 开始
   if(j!=cut&&vis[j]==false){
    DFS(j);
    block++;
   }
  } 
  printf("%d\n",block-1);
 }
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值