PAT日志 1155

顽强的小白

1155 Heap Paths (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.
Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.
Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题目解析

今天打算写堆的题目来着,就想到这道题,结果发现并不是。
给出以静态数组储存的堆,(也可以按照题目说的是个完美二叉树),判断是大根堆,还是小根堆,输出这棵树上的每一条从根到叶的路径,注意是从右往左。

看到输出路径这个要求,恍然大悟不是用堆的算法,果断用了DFS,在递归的过程中判断堆的属性,并且输出路径,一套搞定,考试的时候太紧张,没想清楚,哎,还是技术不到家。

代码实现

#include <cstdio> 
#include <algorithm> 
#include <vector> 
using namespace std; 
const int maxn=1005; 
int heap[maxn];
int n;
vector<int> path;
int tag=0;
void print(){
 for(int i=0;i<path.size();++i){
  printf("%d",path[i]);
  if(i<path.size()-1) printf(" ");
  else printf("\n");
 }
}
void DFS(int index){
 if(index>n) return;
 path.push_back(heap[index]);
 if(index*2>n){ //表示到达叶子了
  print();
 }
 if(index>1&&heap[index]>heap[index/2]&&tag==0){
  tag=1;   //小根 
 }else if(index>1&&heap[index]<heap[index/2]&&tag==0){
  tag=2; //大根 
 }else if(index>1&&tag==1&&heap[index]<heap[index/2]){
  tag=3; //nothing
 }else if(index>1&&heap[index]>heap[index/2]&&tag==2){
  tag=3; //nothing
 }  
 DFS(index*2+1); //这样的顺序就能保证是从右向左的输出了
 DFS(index*2);
 path.pop_back();
 
}
int main(){
 scanf("%d",&n) ;
 for(int i=1;i<=n;++i){
  scanf("%d",&heap[i]);
 }
 DFS(1);
 if(tag==1){
  printf("Min Heap\n");
 }else if(tag==2){
  printf("Max Heap\n"); 
 }else {
  printf("Not Heap\n");
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值