HDU1317 - XYZZY - 最短路判负环+dfs

1.题目描述:

XYZZY

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5281    Accepted Submission(s): 1503


Problem Description
It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable. 
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms. 

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time. 
 

Input
The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing: 

the energy value for room i 
the number of doorways leaving room i 
a list of the rooms that are reachable by the doorways leaving room i 
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case. 
 

Output
In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless". 
 

Sample Input
  
  
5 0 1 2 -60 1 3 -60 1 4 20 1 5 0 0 5 0 1 2 20 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 21 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 20 2 1 3 -60 1 4 -60 1 5 0 0 -1
 

Sample Output
  
  
hopeless hopeless winnable winnable
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1384  1531  1546  1271  1596 
 
2.题意概述:

某人从节点1出发想到节点n,初始能量是100,每走到负边则能量增加,走到正边则能量减少,当能量小于0则失败,问你有没有可能从顶点1走到n?

3.解题思路:

分几种情况考虑:

如果全是正边,则直接spfa判断能否到达终点

如果存在负边,则利用spfa性质,如果能走到含有负边的地方,那么接下来肯定可以获得无穷能量(多走几次负边,获得足够多能量到达终点),就只需要判断能不能走到终点了,这就可以通过dfs直接实现。

ps:当然邻接表判断是否负环好像我这个写法有点问题,但是依然过了.

4.AC代码:

#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
#define maxn 100100
#define N 111
#define eps 1e-6
#define pi acos(-1.0)
#define e exp(1.0)
using namespace std;
const int mod = 1e9 + 7;
typedef long long ll;
typedef unsigned long long ull;
struct node
{
	int to, val;
	node(int a, int b) { to = a; val = b; }
};
vector<node> mp[N];
int dis[N], in[N];
bool vis[N];
bool ans;
int flag;
void dfs(int u, int n)
{
	if (u == n)
	{
		ans = 1;
		return;
	}
	vis[u] = 1;
	int sz = mp[u].size();
	for (int i = 0; i < sz; i++)
	{
		int v = mp[u][i].to;
		if (!vis[v])
			dfs(v, n);
	}
}
void spfa(int sta, int n)
{
	memset(vis, 0, sizeof(vis));
	memset(dis, 0, sizeof(dis));
	memset(in, 0, sizeof(in));
	deque<int> q;
	dis[sta] = 100;
	vis[sta] = 1;
	q.push_back(sta);
	while (!q.empty())
	{
		int u = q.front();
		q.pop_front();
		vis[u] = 0;
		int sz = mp[u].size();
		for (int i = 0; i < sz; i++)
		{
			int v = mp[u][i].to;
			int val = mp[u][i].val;
			if (dis[v] < dis[u] + val)
			{
				dis[v] = dis[u] + val;
				in[v]++;
				if (in[v] == n)
				{
					flag = v;
					return;
				}
				if (!vis[v] && dis[v] > 0)
				{
					vis[v] = 1;
					if (!q.empty() && dis[v] >= dis[q.front()])
						q.push_front(v);
					else
						q.push_back(v);
				}
			}
		}
	}
}
int main()
{
#ifndef ONLINE_JUDGE
	freopen("in.txt", "r", stdin);
	freopen("out.txt", "w", stdout);
	long _begin_time = clock();
#endif
	int n;
	while (~scanf("%d", &n), n != -1)
	{
		for (int i = 1; i <= n; i++)
			mp[i].clear();
		for (int i = 1; i <= n; i++)
		{
			int w, t, v;
			scanf("%d%d", &w, &t);
			while (t--)
			{
				scanf("%d", &v);
				mp[i].push_back(node(v, w));
			}
		}
		flag = 0;
		spfa(1, n);
		ans = 1;
		if (!flag)
			ans = dis[n] <= 0 ? 0 : 1;
		else
		{
			ans = 0;
			memset(vis, 0, sizeof(vis));
			dfs(flag, n);
		}
		puts(ans ? "winnable" : "hopeless");
	}
#ifndef ONLINE_JUDGE
	long _end_time = clock();
	printf("time = %ld ms.", _end_time - _begin_time);
#endif
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值