Rikka with Tree HDU - 5423

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them: 

For a tree  T T, let  F(T,i) F(T,i) be the distance between vertice 1 and vertice  i i.(The length of each edge is 1). 

Two trees  A A and  B B are similiar if and only if the have same number of vertices and for each  i i meet  F(A,i)=F(B,i) F(A,i)=F(B,i)

Two trees  A A and  B B are different if and only if they have different numbers of vertices or there exist an number  i i which vertice  i i have different fathers in tree  A A and tree  B B when vertice 1 is root. 

Tree  A A is special if and only if there doesn't exist an tree  B Bwhich  A A and  B B are different and  A A and  B B are similiar. 

Now he wants to know if a tree is special. 

It is too difficult for Rikka. Can you help her?
Input
There are no more than 100 testcases. 

For each testcase, the first line contains a number  n(1n1000) n(1≤n≤1000).

Then  n1 n−1 lines follow. Each line contains two numbers  u,v(1u,vn) u,v(1≤u,v≤n) , which means there is an edge between  u u and  v v.
Output
For each testcase, if the tree is special print "YES" , otherwise print "NO".
Sample Input
3
1 2
2 3
4
1 2
2 3
1 4
Sample Output
YES
NO


        
  
Hint
For the second testcase, this tree is similiar with the given tree:
4
1 2
1 4
3 4

题解:这道题 最重要就是理解题意 什么样的树是特殊的 就是 一个点他如果有爷爷 那么他的爷爷的孩子只能有一个 

#include<iostream>
#include<cstdio>
#include<string.h>
#include<string>
#include<queue>
#include<map>
#include<algorithm>
#include<vector>
using namespace std;
int pre[1100];
int main()
{
    int n;
    map<int,int>q;
    while(~scanf("%d",&n))
    {
     q.clear();
     for(int i=1;i<=n;i++)
        pre[i]=i;
     int a,b;
     for(int i=1;i<n;i++)
     {
         scanf("%d%d",&a,&b);
         pre[b]=a;
         q[a]++;
     }
     int flag=1;
     for(int i=1;i<=n;i++)
     {
         if(pre[pre[i]]!=pre[i]&&q[pre[pre[i]]]>1)
         {
             flag=0;
         }
     }
     if(flag)
        printf("YES\n");
     else
         printf("NO\n");
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值