HDU 3488--Tour(二分图最小完备匹配,KM算法)


In the kingdom of Henryy, there are N (2 <= N <= 200) cities, with M (M <= 30000) one-way roads connecting them. You are lucky enough to have a chance to have a tour in the kingdom. The route should be designed as: The route should contain one or more loops. (A loop is a route like: A->B->……->P->A.) 
Every city should be just in one route. 
A loop should have at least two cities. In one route, each city should be visited just once. (The only exception is that the first and the last city should be the same and this city is visited twice.) 
The total distance the N roads you have chosen should be minimized. 
Input
An integer T in the first line indicates the number of the test cases. 
In each test case, the first line contains two integers N and M, indicating the number of the cities and the one-way roads. Then M lines followed, each line has three integers U, V and W (0 < W <= 10000), indicating that there is a road from U to V, with the distance of W. 
It is guaranteed that at least one valid arrangement of the tour is existed. 
A blank line is followed after each test case.
Output
For each test case, output a line with exactly one integer, which is the minimum total distance.
Sample Input
1
6 9
1 2 5
2 3 5
3 1 10
3 4 12
4 1 8
4 6 11
5 4 7
5 6 9
6 5 4
Sample Output
42

题意 :找一条环路 路过所有的城镇 求最短长度

解 :每个城镇都有一个 出点u  和一个入点u' ,找出完备匹配,起点出现两次正好出点和入点都被经过 。一般km算法是求最大的值 我们要求最小值 那么 先把所以的值变成-INF 然后路径存相反数   结果取相反数则为所求

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
const int INF = 0x3f3f3f3f;
using namespace std;
int n,m;
int mp[300][300];//记录各个城市距离
int b1[300];//记录出点的期望
int b2[300];//记录入点的期望
int v1[300];//记录每一轮出点匹配过的点
int v2[300];//记录每一轮入点匹配过的点
int p[300];//记录出点匹配到的入点 ,未匹配为-1
int s[300];//记录每个入点的最小期望
int dfs(int u)
{
    v1[u]=1;
    for(int i=1;i<=n;i++)
    {
        if(v2[i]) continue;//每一轮匹配 入点尝试一次
        int gap=b1[u]+b2[i]-mp[u][i];
        if(!gap)
        {
            v2[i]=1;
            if(p[i]==-1||dfs(p[i]))//找一个没被匹配的入点或者这个出点的入点可以匹配别的出点
            {
                p[i]=u;
                return 1;
            }
        }
        else
            s[i]=min(gap,s[i]);
    }
    return 0;
}
int km()
{
    memset(p,-1,sizeof(p));
    memset(b2,0,sizeof(b2));
    for(int i=1;i<=n;i++)//找出最大的距离
    {
        b1[i]=-INF;
        for(int j=1;j<=n;j++)
            b1[i]=max(b1[i],mp[i][j]);
    }
    for(int i=1;i<=n;i++)
    {
        memset(s,INF,sizeof(s));//因为要取最小值,先无穷大
        while(1)
        { 
          //为所以出点找到入点的方法: 找不到就降低期望 直达找到
          memset(v1,0,sizeof(v1));
          memset(v2,0,sizeof(v2));
           if(dfs(i)) break;//找到退出
            int d=INF;
            for(int j=1;j<=n;j++)//找不到 降低期望  找最小可降低期望
                if(!v2[j]) d=min(d,s[j]); 
            for(int j=1;j<=n;j++)
            {
                if(v1[j]) b1[j]-=d;//所有访问过的出点降低期望
                if(v2[j]) b2[j]+=d;//所有访问过的入点增高期望
                else s[j]-=d;//没访问的入点,因为出点期望降低,所以入点所需期望降低
            }
        }
    }
    int res=0;
    for(int i=1;i<=n;i++)
           res+=mp[p[i]][i];
    return res;
}
int main()
{
    int t,a,b,c;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(mp,-INF,sizeof(mp));//先把所有的距离变成-INF
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            mp[a][b]=max(mp[a][b],-c);//可能有重复的路径 找出其中最大的
        }
        printf("%d\n",-km());
    }
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值