poj1144-Network(求割点)

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting
several places numbered by integers from 1 to N. No two places have the same number. The lines
are bidirectional and always connect together two places and in each place the lines end in a telephone
exchange. There is one telephone exchange in each place. From each place it is possible to reach
through lines every other place, however it need not be a direct connection, it can go through several
exchanges. From time to time the power supply fails at a place and then the exchange does not operate.
The officials from TLC realized that in such a case it can happen that besides the fact that the place
with the failure is unreachable, this can also cause that some other places cannot connect to each other.
In such a case we will say the place (where the failure occured) is critical. Now the officials are trying
to write a program for finding the number of all such critical places. Help them.
Input
The input file consists of several blocks of lines. Each block describes one network. In the first line
of each block there is the number of places N < 100. Each of the next at most N lines contains the
number of a place followed by the numbers of some places to which there is a direct line from this place.
These at most N lines completely describe the network, i.e., each direct connection of two places in
the network is contained at least in one row. All numbers in one line are separated by one space. Each
block ends with a line containing just ‘0’. The last block has only one line with N = 0.
Output
The output contains for each block except the last in the input file one line containing the number of
critical places.
Sample Input
5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0
Sample Output
1

2

求无向连通图的割点

 http://www.cnblogs.com/en-heng/p/4002658.html

我们可以发现有两类节点可以成为割点:

  1. 对根节点u,若其有两棵或两棵以上的子树,则该根结点u为割点;
  2. 对非叶子节点u(非根节点),若其子树的节点均没有指向u的祖先节点的回边,说明删除u之后,根结点与u的子树的节点不再连通;则节点u为割点。

对于根结点,显然很好处理;但是对于非叶子节点,怎么去判断有没有回边是一个值得深思的问题。

我们用dfn[u]记录节点u在DFS过程中被遍历到的次序号,low[u]记录节点u或u的子树通过非父子边追溯到最早的祖先节点(即DFS次序号最小),那么low[u]的计算过程如下:

low[u]={min{low[u], low[v]}min{low[u], dfn[v]}(u,v)(u,v)vu

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<stack>
#define nn 110
#define inff 0x3fffffff
using namespace std;
int n,m,num,p[nn],ans,df,fa[nn],dfn[nn],low[nn],kk[nn];
struct node
{
    int en,next;
}E[nn*nn];
int init()
{
 memset(p,-1,sizeof(p));
 num=0;
}
int add(int st,int en)
{
    E[num].en=en;
    E[num].next=p[st];
    p[st]=num++;
}
int dfs(int u)
{
    int child=0;
    dfn[u]=low[u]=++df;
    int w;
    for(int i=p[u];i+1;i=E[i].next)
    {
        w=E[i].en;
        if(dfn[w]==-1)
        {
            child++;
            fa[w]=u;
            dfs(w);
            low[u]=min(low[u],low[w]);
            if(fa[u]==-1&&child>1)
            {
                if(kk[u]==0)
                {
                ans++;
                kk[u]=1;
                }
            }
            if(fa[u]!=-1&&low[w]>=dfn[u])
            {
                if(kk[u]==0)
                {
                ans++;
                kk[u]=1;
                }
            }
        }
        else if(w!=fa[u])
          low[u]=min(low[u],dfn[w]);
    }
}
int slove()
{
    ans=0;
    df=0;
    memset(dfn,-1,sizeof(dfn));
    memset(fa,-1,sizeof(fa));
    memset(kk,0,sizeof(kk));
    for(int i=1;i<=n;i++)
    {
        if(dfn[i]==-1)
            dfs(i);
    }
    printf("%d\n",ans);
}
int main()
{
    int u,v;
    while(~scanf("%d",&n)&&n)
    {
        init();
        while(scanf("%d",&u)&&u)
        {
            while(getchar()!='\n')
            {
                scanf("%d",&v);
                add(u,v);
                add(v,u);
            }
        }
        slove();
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值