简单广搜:Catch That Cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers:  N and  K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.



思路:这道题就是一个广搜队列实现模板题,建议广搜想入门的同学先看模板,然后分析模板,然后写出自己的模板,打出自己的思路,因为简单题看的是模板,难题考的是思路。

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<iostream>
#define N 100010
using namespace std;
bool map[N];
int n,k;
int d[3]= {-1,1,2};
struct node
{
    int s,t;
};
bool check(int m)
{
    if(m<0||m>=N||map[m])
        return 0;
    return 1;
}
void bfs()
{
    queue<node> q;
    node first,next;
    first.s=n;
    first.t=0;
    q.push(first);
    map[first.s]=1;
    while(!q.empty())
    {
        first=q.front();
        q.pop();
        for(int i=0; i<3; i++)
        {
            if(i!=2)
                next.s=first.s+d[i];
            else
                next.s=first.s*d[i];
            if(next.s==k)
            {
                printf("%d\n",first.t+1);
                return ;
            }
            if(check(next.s))
            {
                next.t=first.t+1;
                map[next.s]=1;
                q.push(next);
            }
        }
    }
    printf("-1\n");
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        memset(map,0,sizeof(map));
        if(n==k)
        {
            printf("0\n");
            continue;
        }
        bfs();
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值