Poj_3984走迷宫(广搜)

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)


求最短路径既是广搜思想,可用数组模拟队列,直到队列为空或者找到目标节点即结束,代码如下:

#include<iostream>
#include<stdio.h>

using namespace std;

struct node{
	int x;
	int y;
	int pre;
}path[100];

int dirx[4]={0,0,1,-1};
int diry[4]={1,-1,0,0};

int map[5][5];
int front=0,rear=1;

void print(int i){
	if(path[i].pre!=-1){	//找到始点后再开始输出节点 
		print(path[i].pre);
		printf("(%d, %d)\n",path[i].x,path[i].y);	
		
	}
	else
		printf("(%d, %d)\n",path[i].x,path[i].y);	
	
} 

void WFS(int x, int y){
	path[front].x=x;
	path[front].y=y;
	path[front].pre=-1;
	map[x][y]=1;
	bool flag=false;
	while(front<rear){
		for(int i=0; i<4; ++i){
			int px=path[front].x+dirx[i];
			int py=path[front].y+diry[i];
			if(px<0||py<0||px>4||py>4||map[px][py])
				continue;
			else{
				map[px][py]=1;
				path[rear].x=px;	//入队 
				path[rear].y=py;
				path[rear].pre=front;
				rear++;
			}
			if(px==4 && py==4){
				print(rear-1);
				flag=true;
				break;
			}
		}
		front++;
		if(flag)
			break;
	}
}

int main(){
	for(int i=0;i<5;++i)
		for(int j=0; j<5; ++j)
			scanf("%d",&map[i][j]);
	WFS(0,0);
return 0;	
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值