The SetStack Computer出现的问题无法解决

本题我始终WA,但是我还是希望保留我的代码,网上基本上所有解决这道题的代码全是剽窃刘汝嘉的,希望有大神可以告诉我错误原因,万分感谢。

题目:

12096 The SetStack Computer

Background from Wikipedia: Set theory is a branch ofmathematics created principally by the German mathe-matician Georg Cantor at the end of the 19th century.

Initially controversial, set theory has come to play therole of a foundational theory in modern mathematics,
in the sense of a theory invoked to justify assumptionsmade in mathematics concerning the existence of mathe-
matical objects (such as numbers or functions) and theirproperties. Formal versions of set theory also have a
foundational role to play as specifying a theoretical idealof mathematical rigor in proofs."
Given this importance of sets, being the basis ofmathematics, a set of eccentric theorist set off to construct a supercomputer operating on sets in-stead of numbers. The initial SetStack Alpha is under construction, and they need you to simulate it
in order to verify the operation of the prototype.
The computer operates on a single stack of sets, which is initially empty. After each operation, the
cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted jSj and is the
number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT,

and ADD.

PUSH will push the empty set fg on the stack.
DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).
UNION will pop the stack twice and then push the union of the two sets on the stack.
INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.
ADD will pop the stack twice, add the rst set to the second one, and then push the resulting seton the stack.

Input
An integer 0 <= T<= 5 on the rst line gives the cardinality of the set of test cases. The rst line of each
test case contains the number of operations 0 <=N <= 2000. Then follow N lines each containing one of
the ve commands. It is guaranteed that the SetStack computer can execute all the commands in the
sequence without ever popping an empty stack.

Output
For each operation speci ed in the input, there will be one line of output consisting of a single integer.
This integer is the cardinality of the topmost element of the stack after the corresponding command
has executed. After each test case there will be a line with `***' (three asterisks).

Sample Input
2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT

Sample Output
0
0
1
0
1
1
2
2
2
***
0
0
1
0
0
***



错解:

#include<iostream>
#include<set>
#include<string>
#include<stack>
#include<algorithm>

using namespace std;
typedef set<int> Set;

int t,n;

void push(stack<Set>&st)
{
    Set s;
    st.push(s);
}

void dup(stack<Set>&st)
{
    Set temp=st.top();
    st.push(temp);
}

void intersect(stack<Set>&st)
{
    Set temp=st.top();
    st.pop();
    Set tem=st.top();
    st.pop();
    Set t;
    Set::iterator it=temp.begin();
    while(it!=temp.end())
    {
        if(count(tem.begin(),tem.end(),*it)==1)t.insert(*it);
        it++;
    }
    st.push(t);
}

void Union(stack<Set>&st)
{
    Set temp=st.top();
    st.pop();
    Set tem=st.top();
    st.pop();
    Set::iterator it=temp.begin();
    while(it!=temp.end())
    {
        tem.insert(*it);
        it++;
    }
    st.push(tem);
}

void add(stack<Set>&st)
{
    Set temp=st.top();
    st.pop();
    Set tem=st.top();
    st.pop();
    tem.insert(temp.size());
    st.push(tem);
}


int main()
{
    string op;
    cin>>t;
    while(t--)
    {
        stack<Set>st;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>op;
            if(op=="PUSH")push(st);
            if(op=="DUP")dup(st);
            if(op=="INTERSECT")intersect(st);
            if(op=="UNION")Union(st);
            if(op=="ADD")add(st);
            cout<<(st.top()).size()<<endl;
        }
        cout<<"***"<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

水能zai舟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值