HDU_3555_Bomb

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 19824    Accepted Submission(s): 7365


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

Source

2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU


  • 和HDU2089类似
  • 数位dp[i][j]处理第i位以j开头的全体无49的整数(含0)
  • 计算cal(n)会漏掉n本身
  • 详见代码

#include <iostream>
#include <string>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <climits>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
typedef long long           LL ;
typedef unsigned long long ULL ;
const int    maxn = 1e3 + 10   ;
const int    inf  = 0x3f3f3f3f ;
const int    npos = -1         ;
const int    mod  = 1e9 + 7    ;
const int    mxx  = 100 + 5    ;
const double eps  = 1e-6       ;
const double PI   = acos(-1.0) ;

LL dp[20][11];
int d[20], tot;
void init(void){
	dp[0][0]=1LL;
	for(int i=1;i<20;i++)
		for(int j=0;j<10;j++)
			for(int k=0;k<10;k++)
				if(!(j==4&&k==9))
					dp[i][j]+=dp[i-1][k];
}
LL cal(LL n){
	LL res=0;
	tot=0;
	while(n){
		d[++tot]=n%10;
		n/=10;
	}
	d[tot+1]=0;
	for(int i=tot;i>0;i--){
		for(int j=0;j<d[i];j++){
			if(!(d[i+1]==4&&j==9)){
				res+=dp[i][j];
			}
		}
		if(d[i+1]==4 && d[i]==9){
			break;
		}
	}
	return res;
}
int T;
LL n;
int main(){
	// freopen("in.txt","r",stdin);
	// freopen("out.txt","w",stdout);
	init();
	while(~scanf("%d",&T)){
		while(T--){
			scanf("%lld",&n);
			printf("%lld\n",n+1-cal(n+1));
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值