Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
Output
Print how many keywords are contained in the description.
Sample Input
1
5
she
he
say
shr
her
yasherhs
Sample Output
3
大致题意:让你求目标串中出现了几个模式串
思路:最基础的ac自动机,直接套模板
(注意:模式串可能会重复)
代码如下
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
#include<cmath>
#include<string>
#include<map>
#define LL long long
using namespace std;
const int maxn=26;
struct Trie
{
int next[500010][maxn];
int fail[500010],end[500010];
int root,L;
int newnode() //初始化
{
for(int i=0;i<26;i++)
next[L][i]=-1;
end[L++]=0;
return L-1;
}
void init()//初始化
{
L=0;
root=newnode();
}
void insert(char s[])//构造树trie
{
int len=strlen(s);
int now=root;
for(int i=0;i<len;i++)
{
if(next[now][s[i]-'a']==-1)
next[now][s[i]-'a']=newnode();
now=next[now][s[i]-'a'];
}
end[now]++;
}
void build()//构造失败指针
{
queue<int>Q;
fail[root]=root;
for(int i=0;i<26;i++)
if(next[root][i]==-1)
next[root][i]=root;
else
{
fail[next[root][i]]=root;
Q.push(next[root][i]);
}
while(!Q.empty())
{
int now=Q.front();
Q.pop();
for(int i=0;i<26;i++)
if(next[now][i]==-1)
next[now][i]=next[fail[now]][i];
else
{
fail[next[now][i]]=next[fail[now]][i];
Q.push(next[now][i]);
}
}
}
void query(char buf[])//查询
{
int len=strlen(buf);
int now=root;
int sum=0;
for(int i=0;i<len;i++)
{
now = next[now][buf[i]-'a'];
int temp = now;
while(temp != root)
{
sum+=end[temp];
end[temp]=0;//避免重复计算
temp = fail[temp];
}
}
printf("%d\n",sum);
}
};
char str1[55];
char str2[1000010];
Trie ac;
int main()
{
int n,m;
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
ac.init();
for(int i = 1;i <= n;i++)
{
scanf("%s",str1);
ac.insert(str1);
}
ac.build();
scanf("%s",str2);
ac.query(str2);
}
return 0;
}