Keywords Search (HDU-2222)(AC自动机模板题)

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input

First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.

Output

Print how many keywords are contained in the description.

Sample Input

1
5
she
he
say
shr
her
yasherhs

Sample Output

3

题意:给你一个长度为n的单词表,一个文本串,问你这个文本串中出现了单词表中多少个单词。

思路:直接套用AC自动机的模板即可。

AC代码:

#include <bits/stdc++.h>
typedef long long ll;
const int maxx=500010;
const int maxn=26;
const int inf=0x3f3f3f3f;
using namespace std;
int Trie[maxx][maxn];
int fail[maxx];
int cntword[maxx];
//bool visit[maxx];//另一种模板
char s[1000010];
int k;
void init()
{
    memset(Trie,0,sizeof(Trie));
    memset(cntword,0,sizeof(cntword));
    //memset(visit,0,sizeof(visit));
    memset(fail,0,sizeof(fail));
    k=0;
}
void insert(char *s)
{
    int p=0;
    int len=strlen(s);
    for(int i=0; i<len; i++)
    {
        int c=s[i]-'a';
        if(!Trie[p][c])
        {
            Trie[p][c]=++k;
        }
        p=Trie[p][c];
    }
    cntword[p]++;
}
void build()
{
    queue<int>q;
    for(int i=0; i<26; i++)
    {
        if(Trie[0][i])
        {
            fail[Trie[0][i]]=0;
            q.push(Trie[0][i]);
        }
    }
    while(!q.empty())
    {
        int now=q.front();
        q.pop();
        for(int i=0; i<26; i++)
        {
            if(Trie[now][i])
            {
                fail[Trie[now][i]]=Trie[fail[now]][i];
                q.push(Trie[now][i]);
            }
            else
                Trie[now][i]=Trie[fail[now]][i];
        }
    }
}
int query(char *s)
{
    int now=0;
    int ans=0;
    int len=strlen(s);
//    for(int i=0; i<len; i++)
//    {
//        visit[now]=1;
//        int c=s[i]-'a';
//        int y=Trie[now][c];
//        while(y && !visit[y])
//        {
//            visit[y]=1;
//            if(cntword[y])
//            {
//                ans=ans+cntword[y];
//                cntword[y]=0;
//            }
//            y=fail[y];
//        }
//        root=Trie[now][c];
//    }
    for(int i=0; i<len; i++)
    {
        now=Trie[now][s[i]-'a'];
        for(int j=now; j && cntword[j]!=-1; j=fail[j])
        {
            ans+=cntword[j];
            cntword[j]=-1;
        }
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        init();
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%s",s);
            insert(s);
        }
        build();
        scanf("%s",s);
        printf("%d\n",query(s));
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值