poj1696 Space Ant (极角排序,叉积)

Description

The most exciting space discovery occurred at the end of the 20th century. In 1999, scientists traced down an ant-like creature in the planet Y1999 and called it M11. It has only one eye on the left side of its head and just three feet all on the right side of its body and suffers from three walking limitations:
It can not turn right due to its special body structure.
It leaves a red path while walking.
It hates to pass over a previously red colored path, and never does that.

The pictures transmitted by the Discovery space ship depicts that plants in the Y1999 grow in special points on the planet. Analysis of several thousands of the pictures have resulted in discovering a magic coordinate system governing the grow points of the plants. In this coordinate system with x and y axes, no two plants share the same x or y.
An M11 needs to eat exactly one plant in each day to stay alive. When it eats one plant, it remains there for the rest of the day with no move. Next day, it looks for another plant to go there and eat it. If it can not reach any other plant it dies by the end of the day. Notice that it can reach a plant in any distance.
The problem is to find a path for an M11 to let it live longest.
Input is a set of (x, y) coordinates of plants. Suppose A with the coordinates (xA, yA) is the plant with the least y-coordinate. M11 starts from point (0,yA) heading towards plant A. Notice that the solution path should not cross itself and all of the turns should be counter-clockwise. Also note that the solution may visit more than two plants located on a same straight line.
这里写图片描述
Input

The first line of the input is M, the number of test cases to be solved (1 <= M <= 10). For each test case, the first line is N, the number of plants in that test case (1 <= N <= 50), followed by N lines for each plant data. Each plant data consists of three integers: the first number is the unique plant index (1..N), followed by two positive integers x and y representing the coordinates of the plant. Plants are sorted by the increasing order on their indices in the input file. Suppose that the values of coordinates are at most 100.
Output

Output should have one separate line for the solution of each test case. A solution is the number of plants on the solution path, followed by the indices of visiting plants in the path in the order of their visits.
Sample Input

2
10
1 4 5
2 9 8
3 5 9
4 1 7
5 3 2
6 6 3
7 10 10
8 8 1
9 2 4
10 7 6
14
1 6 11
2 11 9
3 8 7
4 12 8
5 9 20
6 3 2
7 1 6
8 2 13
9 15 1
10 14 17
11 13 19
12 5 18
13 7 3
14 10 16
Sample Output

10 8 7 3 4 9 5 6 2 1 10
14 9 10 11 5 12 8 7 6 13 4 14 1 3 2

思路:第一步肯定是取最左下角的那个点,假设当前在pos点,然后接下来要取的点即剩下点中从pos点出发的左偏量最小的那个点,利用叉积进行排序。

代码如下

#include<iostream>
#include<set>
#include<vector>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
typedef long long ll;
const double eps=1e-8;
const double INF=0x3f3f3f3f;

int dcmp(double x) 
{
    if(fabs(x)<eps) return 0;
    return x<0?-1:1;
}
struct Point 
{
    int x,y;
    int id;
    Point() {}
    Point(int  _x,int _y,int _id)
    {
        x=_x;
        y=_y;
        id=_id;
    }
    Point operator-(const Point &b) const {
        return Point(x-b.x,y-b.y,id);
    }
    int operator *(const Point &b)const {
        return x*b.x + y*b.y;
    }
    int operator ^(const Point &b)const {
        return x*b.y - y*b.x;
    }
    int operator ==(const Point &b)const {
        if(dcmp(x-b.x)==0&&dcmp(y-b.y)==0)//两点相同 
        return 0;
        else return 1;
    }
};


double xmult(Point p0,Point p1,Point p2)//叉积 
{
    return (p1-p0)^(p2-p0);
}
double dist(Point a, Point b) {  
    return sqrt((a - b) * (a - b));  
}  
const int N=60;
int pos;
Point dian[N];
bool cmp(Point a,Point b)
{
    double f=xmult(dian[pos],a,b);
    if(dcmp(f)==0) return dist(a,dian[pos])<dist(b,dian[pos]);//如果两个点的极角相同那么取距离pos点距离最近的 
    else if(dcmp(f)>0) return 1;//如果叉积大于0,说明到a点的极角小于b 
    else return 0;
}
int main() 
{
    int T;
    int n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&dian[i].id,&dian[i].x,&dian[i].y);
            if(dian[i].y<dian[0].y||(dian[i].y==dian[0].y&&dian[i].x<dian[0].x))
            swap(dian[i],dian[0]);
        }
        pos=0;
        for(int i=1;i<n;i++)
        {
            sort(dian+i,dian+n,cmp);
            pos++;
        }
        printf("%d",n);
        for(int i=0;i<n;i++)
            printf(" %d",dian[i].id);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值