Number Triangle

Problem 1004 Number Triangle

Accept: 2248    Submit: 5973
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

7 3 8 8 1 0 2 7 4 44 5 2 6 5

In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

Input

There are multiple test cases.The first line of each test case contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.

Output

Print a single line containing the largest sum using the traversal specified for each test case.

Sample Input

573 88 1 02 7 4 44 5 2 6 5

Sample Output

30 






#include <stdio.h>
int a[1005][1005];    //第一次定在main内部  堆空间不够 无法创建
int findmax(int i,int j,int R);
int main(){
  int R;
  while(scanf("%d",&R)!=EOF){
    int i,j;
    for(i=0;i<R;i++){
      for(j=0;j<=i;j++)
        scanf("%d",&a[i][j]);
    }
    int max=findmax(0,0,R);
    printf("%d\n",max);
  }
  return 0;
}
int findmax(int i,int j,int R){
  if(i<R-1){
    int left,right;
    left=findmax(i+1,j,R);
    right=findmax(i+1,j+1,R);
    return left>right?left:right + a[i][j];
  }
  return a[i][j];
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值