A+B for Matrices(JAVA)

题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5
来源:

2011年浙江大学计算机及软件工程研究生机试真题

PS:这题是从九度题库里找到的 。

最近在用java,于是使用java编程语言来实现。

正常的思路应该是这样:

1、实现两个矩阵的输入,可以通过二维数组实现。

这里为了节省空间消耗,可以只适用一个数组,第二个数组输入时直接对应相加即可。

2、分别横向和纵向对数组遍历,统计符合条件项的个数,并输出。

代码:

import java.util.*;
public class Main
{
	 public static void main(String args[])
	    {
	    int M,N;
	    Scanner cin = new Scanner(System.in);
	    while(cin.hasNext())
	    {
	        int sum = 0;
	        M = cin.nextInt();
	        if(M==0)break;
	        N = cin.nextInt();
	        int A[][] = new int[M][N];
	        int B[][] = new int[M][N];
	        for(int i=0;i<M;i++)
	            for(int j=0;j<N;j++)
	            A[i][j] = cin.nextInt();
	        for(int i=0;i<M;i++)
	            for(int j=0;j<N;j++)
	            B[i][j] = cin.nextInt();
	        for(int i=0;i<M;i++)
	            for(int j=0;j<N;j++)
	            A[i][j] = A[i][j]+B[i][j];
	        for(int i=0;i<M;i++)
	        {
	        	int j=0;
	            for(;j<N;j++)
	            {
	                if(A[i][j] != 0)break;	                
	            }
	            if(j == N)sum++;
	        }
	        for(int i=0;i<N;i++)
	        {
	        	int j=0;
	            for(;j<M;j++)
	            {
	                if(A[j][i] != 0)break;
	            }
	            if(j == M)sum++;
	        }
	    System.out.println(sum);
	    }
	     
	     
	    }
	}

改进思路:

1、仍然是输入。考虑用空间换时间,这里增加一个一维数组(M+N的大小),对应各列和各行,初始值为0,如果该列(行)有不为0的数值,该数组项加一,由于可以放在第二个二维数组输入的循环里,所以可以避免后期循环。

2、统计一维数组中0值的大小。

代码:

mport java.util.*;
public class Main
{
    public static void main(String args[])
    {
    int M,N;
    Scanner cin = new Scanner(System.in);
    while(cin.hasNext())
    {
        int sum = 0;
        M = cin.nextInt();
        if(M==0)break;
        N = cin.nextInt();
        if(N==0)break;
        int A[][] = new int[M][N];
        int tmp[] = new int[M+N];
        for(int i=0;i<M;i++)
            for(int j=0;j<N;j++)
            A[i][j] = cin.nextInt();
        for(int i=0;i<M+N;i++)tmp[i]=0;
        for(int i=0;i<M;i++)
            for(int j=0;j<N;j++)
            {
            A[i][j] += cin.nextInt();
            if(A[i][j] !=0)
                {
                tmp[i]++;
                tmp[M+j]++;
                }
            }
        for(int i=0;i<M+N;i++)
            {
            if(tmp[i] == 0)sum++;
            }
    System.out.println(sum);
    }
     
     
    }
}
/**************************************************************
    Problem: 1001
    User: xjtuyelei
    Language: Java
    Result: Accepted
    Time:1700 ms
    Memory:17816 kb
****************************************************************/

问题结束,欢迎讨论。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值