最大生成树 之 kruskal Bad Cowtractors POJ - 2377

原题:

     Bad Cowtractors

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

题意: 在保证是通路的情况下,修理工想修最长的线路,这样能挣得更多的钱(黑心)

解题思路:和最小生成树相反,把权值大的排在前面

#include<cstdio>
#include<algorithm>
using namespace std;
int m,n,k;
int fa[1005];
struct node{
	int s,e,w;
}a[20005];
bool cmp(node a,node b){    // 对结构体中权值从大到小排序 
	return a.w > b.w;
}
int get(int i){       // 获得其 父节点 并进行路径压缩 
    if(fa[i] != i){
	    fa[i] = get(fa[i]);
    }
    return fa[i];
}
int kruskal(){
	sort(a,a+k,cmp);
	int ans = 0;
	for(int i = 0;i < k;i++){  // 循环合并节点 
		int x = get(a[i].s);
		int y = get(a[i].e);
		if(x != y){         // 父节点 不同,进行合并 
			fa[x] = y;
			ans += a[i].w;  // 答案求和 
		}
	}
	return ans;
}
int main(){
	while(scanf("%d%d",&n,&m) != EOF){
		k = 0;
		for(int i = 1;i <= n;i++){
			fa[i] = i;
		}
		for(int i = 1;i <= m;i++){
			int x,y,z;
			scanf("%d%d%d",&x,&y,&z);
			a[k].s = x;
			a[k].e = y;
			a[k].w = z;
			k++;
		}
		int f = 0;
		int ans = kruskal();
		for(int i = 1;i <= n;i++){   // 不是通路,返回-1 
			if(fa[i] == i){
				f++;
			}
		}
		if(f > 1){
			printf("-1\n");
		}
		else{
			printf("%d\n",ans);
		}
	}
	return 0;
} 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值