People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red
, the middle 2 digits for Green
, and the last 2 digits for Blue
. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168)(168是因为两位十三进制数能表示的最大范围是12*13+12=168), you are supposed to output their Mars RGB values.
Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.
Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #
, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0
to its left.
Sample Input:
15 43 71
Sample Output:
#123456
代码:
#include<iostream>
using namespace std;
int main()
{
char Radix_13[13]={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
char RGB_Mars[6]={'0','0','0','0','0','0'};
int RGB_earth[3];
scanf("%d%d%d",RGB_earth,RGB_earth+1,RGB_earth+2);
for(int i=0;i<3;i++)
{
RGB_Mars[2*i+1]=Radix_13[RGB_earth[i]%13];
RGB_Mars[2*i+0]=Radix_13[RGB_earth[i]/13];
}
printf("#");
for(int i=0;i<6;i++)
printf("%c",RGB_Mars[i]);
return 0;
}