1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105), the total number of diamonds on the chain, and M (≤108), the amount that the customer has to pay. Then the next line contains N positive numbers D1​⋯DN​ (Di​≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

 代码:

#include<iostream>
using namespace std;
int main()
{
    int N,M,flag=0;//flag用来存放是否存在连续的钻石使得这些钻石价值之和正好等于M
    int diamond[100010],index[2][100010],count=0;//index数组用来存放sum大于M的情况下的i,j值,count用来记录满足Min值的i-j对的个数
    scanf("%d%d",&N,&M);//输入数据
    for(int i=0;i<N;i++)//输入每颗钻石的价值
        scanf("%d",&diamond[i]);
    int i_index=0,j_index=0,Min=100000010,sum=diamond[0];//i_index存放i,j_index存放j值,Min用来存放大于M的最小和,sum用来存放i-j的钻石的价值之和
    while(i_index<N)//循环条件
    {
        if(sum<M)//sum小于M时
        {
            j_index=j_index+1;//j下标前移
            if(j_index==N)//j坐标越界,则退出循环
                break;
            sum+=diamond[j_index];//sum加上j所指钻石的价值
        }
        else if(sum==M)//sum等于M时
        {
            flag=1;//flag标志置1,表明存在连续的几个钻石价值之和正好等于M
            printf("%d-%d\n",i_index+1,j_index+1);//此时输出i-j的值
            sum-=diamond[i_index++];//让i下标前移
        }
        else if(sum>M)//sum大于M时
        {
            if(sum<Min)//如果sum小于min
            {
                Min=sum;//设置新的Min
                count=1;//count记录满足Min的个数
                index[0][0]=i_index;//记录此时的i、j的坐标
                index[1][0]=j_index;
            }
            else if(sum==Min)
            {
                index[0][count]=i_index;
                index[1][count]=j_index;
                count++;
            }
            sum-=diamond[i_index++];//i下标前移
        }
    }
    if(flag==0)//若不存在连续的钻石使得其价值之和正好等于M
        for(int i=0;i<count;i++)//则输出使得连续钻石价值之和sum>M,并且sum取值最小时的i-j值
            printf("%d-%d\n",index[0][i]+1,index[1][i]+1);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值