1044 Shopping in Mars(二分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

题目大意

给出手链上n个钻石的价格,以及顾客买钻石想要花的钱m,从n个钻石中取出若干个连续的钻石,使所花的总价恰好等于m,输出起始位置及结束位置,若不存在恰好等于m的,则使总价为大于等于m的最小值。

思路

先学习一下lower_bound()/upper_bound()函数:
lower_bound( begin, end, num):begin是一段连续空间的首地址,end是连续空间的末地址,num是要查找的值,返回该连续空间中第一个大于等于num的元素下标。
upper_bound( begin, end, num):与lower_bound基本一致,均运用了二分查找的思想,且均适用于元素有序的连续空间,它与lower_bound唯一的区别是,upper_bound返回该连续空间中第一个大于num的元素下标。
(若元素无序,可加入一个比较函数cmp作为参数,与sort类似)

本题中,输入元素时可计算第1个元素到第i个元素的累加sum[i]。(sum[i->j] = sum[i] - sum[j - 1])当给定i时,sum[i->j]显然单调增,可用二分查找lower_bound()函数,返回第一个大于等于m的下标以及最小值mins,再次进行遍历,找出sum[i->j]等于mins的i和j。

AC代码

#include <cstdio>
#include <algorithm>
using namespace std;

int n, m, mins = 1e9;
int sum[100001] = {0}; //价格累加 

int main(){
	scanf("%d%d", &n, &m);
	for(int i = 1; i <= n; i++){
		scanf("%d", &sum[i]);
		sum[i] += sum[i - 1];
	}
	//得到大于等于m的最小值mins 
	for(int i = 1; i <= n; i++){
		//返回第一个大于等于sum[i-1]+m 的sum[j]下标j 
		int j = lower_bound(sum + i, sum + n + 1, sum[i - 1] + m) - sum;
		if(sum[j]- sum[i - 1] == m){
			mins = m;
			break;
		} 
		else if(j <= n && sum[j] - sum[i - 1] < mins){
			mins = sum[j] - sum[i - 1];
		}
	}
	for(int i = 1; i <= n; i++){
		int j = lower_bound(sum + i, sum + n + 1, sum[i - 1] + m) - sum;
		if(sum[j]- sum[i - 1] == mins){
			printf("%d-%d\n", i, j);
		} 		
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值