1081 Rational Sum (20 分)

该代码实现了一个程序,用于接收多个有理数输入,并计算它们的和,确保结果以最简分数形式输出。输入有理数可以为正、负,程序通过结构体存储有理数,使用欧几里得算法进行约分。最后,根据整数部分是否为0决定输出整数还是分数形式。
摘要由CSDN通过智能技术生成

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

 代码:

#include<iostream>
using namespace std;
struct Fraction
{
    long long int up,down;
}num[110];
Fraction add(Fraction a,Fraction b)
{
    Fraction result;
    result.up=a.up*b.down+b.up*a.down;
    result.down=a.down*b.down;
    return result;
}
int gcd(long long int a,long long int b)
{
    if(b==0)
        return a;
    else return gcd(b,a%b);
}
Fraction reduction(Fraction a)
{
    if(a.down<0)
    {
        a.up=-a.up;
        a.down=-a.down;
    }
    if(a.up==0)
        a.down=1;
    else
    {
        int d=gcd(a.up,a.down);
        a.up/=d;
        a.down/=d;
    }
    return a;
}
long long int abs1(long long int a)
{
    if(a<0)
        return -a;
    else
        return a;
}
int main()
{
    int N;
    scanf("%d",&N);
    Fraction sum;
    sum.up=0;
    sum.down=1;
    Fraction a;
    for(int i=0;i<N;i++)
    {
        scanf("%lld/%lld",&a.up,&a.down);
        a=reduction(a);
        sum=add(sum,a);
        sum=reduction(sum);
    }
    if(abs1(sum.up)>sum.down)
    {
        printf("%lld",sum.up/sum.down);
        if(abs1(sum.up)%sum.down)
            printf(" %lld/%lld",abs1(sum.up)%sum.down,sum.down);
    }
    else if(sum.down==1)
        printf("%lld",sum.up);
    else
        printf("%lld/%lld",sum.up,sum.down);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值