1015 Reversible Primes (20 分)

该代码实现了一个程序,用于检查给定基数下的整数是否为回文素数。回文素数是指在特定进制下,其数字反过来仍为素数的数。例如,十进制下的73和23都是回文素数,因为它们的反转37和32也是素数。程序首先找到所有小于100010的素数,然后对于每组输入的整数N和基数D,检查N和其反转数是否都是素数,输出结果为'Yes'或'No'。
摘要由CSDN通过智能技术生成

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

代码: 

#include<iostream>
using namespace std;
const int maxn=100010;
bool p[maxn]={false};
void find_prime()
{
    p[1]=true;//1不是素数也不是合数
    for(int i=2;i<maxn;i++)
    {
        if(p[i]==false)
        {
            for(int j=i+i;j<maxn;j+=i)
                p[j]=true;
        }
    }
}
void IsReversible(int N,int D)
{
    int num[20],d1=0,d2=0,count=0;
    while(N)
    {
        num[count++]=N%D;
        N/=D;
    }
    for(int i=0;i<count;i++)
    {
        d1=d1*D+num[i];
        d2=d2*D+num[count-1-i];
    }
    if(p[d1]==false&&p[d2]==false)
        printf("Yes\n");
    else
        printf("No\n");
}
int main()
{
    find_prime();
    int N,D;
    scanf("%d",&N);
    while(N>=0)
    {
        scanf("%d",&D);
        IsReversible(N,D);
        scanf("%d",&N);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值