1094. The Largest Generation (25)

389 篇文章 1 订阅
140 篇文章 0 订阅

1094. The Largest Generation (25)
时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.
Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M(less than N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.
Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <queue>
#include <iomanip>

using namespace std;
const int MaxN = 110;
int Gner = 0, Num =-1;

struct tnode
{
    vector<int>child;
}Tree[MaxN];


void Level(int root)
{
    queue<int> que, backque;
    que.push(root);
    int tNum = 0, G = 0;

    while (que.size())
    {
        ++G; tNum = 0;
        while (que.size())
        {
            ++tNum;
            int id = que.front(); que.pop();

            for (int i = 0; i < Tree[id].child.size(); ++i)
                backque.push(Tree[id].child[i]);
        }

        if (tNum > Num)
        {
            Num = tNum;
            Gner = G;
        }

        while (backque.size())
        {
            que.push(backque.front());
            backque.pop();
        }

    }

}


int  CreateTree(int Nonchild)
{
    for (int i = 0; i < Nonchild; ++i)
    {
        int id,childnum, child;
        cin >> id >> childnum;

        for (int k = 0; k < childnum; ++k)
        {
            cin >> child;
            Tree[id].child.push_back(child);
        }
    }
    return 0;
}


int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif

    std::ios::sync_with_stdio(false);

    int N, Nonchild;
    cin >> N >> Nonchild;

    CreateTree(Nonchild);
    Level(1);
    cout << Num << " " << Gner;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值