1121. Damn Single (25)

389 篇文章 1 订阅
140 篇文章 0 订阅

1121. Damn Single (25)
时间限制 300 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

“Damn Single (单身狗)” is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID’s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID’s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.
Output Specification:
First print in a line the total number of lonely guests. Then in the next line, print their ID’s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.
Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <string>
#include <cstring>
#include <iomanip>
#include <vector>
#include <map>
#include <set>

using namespace std;
map<string, string>Couple1,Couple2;
set<string> partMember;
vector<string> singleDog;

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG
    std::ios::sync_with_stdio(false);

    int N;
    cin >> N;
    for (int i = 0; i < N; ++i)
    {
        string n1, n2;
        cin >> n1 >> n2;
        Couple1[n1] = n2;
        Couple1[n2] = n1;
    }

    cin >> N;
    for (int i = 0; i < N; ++i)
    {
        string name;
        cin >> name;
        partMember.insert(name);
    }

    for (auto it = partMember.begin();it != partMember.end();++it)
    {
        string coup;
        auto couple1 = Couple1.find(*it);
        auto couple2 = Couple2.find(*it);
        if (couple1 == Couple1.end() && couple2 == Couple2.end())singleDog.push_back(*it);
        else
        {
            auto p = (couple1 == Couple1.end()) ? couple2 : couple1;
            auto CisInPart = partMember.find(p->second);
            if (CisInPart != partMember.end())partMember.erase(CisInPart);
            else singleDog.push_back(*it);
        }
    }

    cout << singleDog.size() << endl;
    for (int i = 0; i < singleDog.size(); ++i)
    {
        cout << singleDog[i];
        if (i != singleDog.size() - 1)cout << " ";
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值