1133. Splitting A Linked List (25)

389 篇文章 1 订阅
140 篇文章 0 订阅

1133. Splitting A Linked List (25)
时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=1000). The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer in [-105, 105], and Next is the position of the next node. It is guaranteed that the list is not empty.
Output Specification:
For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218
Sample Output:
33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

思路:可以借鉴归并排序,将链表分为3大类,在遍历的工程按需分类,最后按照要求合成一个表,最后遍历即可

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <string>
#include <iomanip>


using namespace std;
const int MaxN = 100010;
typedef struct lnode
{
    int addr;
    int data;
    int next;
    lnode() { next = -1; }
}LNode;

LNode List[MaxN]; int N,nodeN = 0;
LNode section[MaxN]; int seN=0;//在区间内的数值
LNode over[MaxN]; int ovN=0;//超过k的数据
LNode negetive[MaxN]; int neN=0;//负数数据
int K;

void Merge(int neN, int seN, int ovN)
{
    int k = 0;
    while (k < neN)List[nodeN++] = negetive[k++];

    k = 0;
    while (k < seN)List[nodeN++] = section[k++];

    k = 0;
    while (k < ovN)List[nodeN++] = over[k++];
}


void print()
{
    int i = 1;
    cout << setw(5) << setfill('0') << List[0].addr;
    cout << " " << List[0].data;
    while (i < nodeN)
    {
        cout << " ";
        cout << setw(5) << setfill('0') << List[i].addr << endl;
        cout << setw(5) << setfill('0') << List[i].addr;
        cout <<" " << List[i++].data;
    }
    cout << " -1";
}

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG
    std::ios::sync_with_stdio(false);
    int startAddr,addr,data,next;
    cin >> startAddr >> N >> K;

    for (int i = 0; i < N; ++i)
    {
        cin >> addr >> data >> next;
        List[addr].addr = addr;
        List[addr].data = data;
        List[addr].next = next;
    }

    /*addr = startAddr;
    while (addr != -1)
    {
        cout << addr <<" " << List[addr].data <<" " << List[addr].next << endl;
        addr= List[addr].next;
    }*/

    addr = startAddr;
    while(addr != -1)
    {
        if (0 <= List[addr].data && List[addr].data <= K)
        {
            section[seN].addr = List[addr].addr;
            section[seN].data = List[addr].data;
            ++seN;
        }
        else if(List[addr].data > K)
        {
            over[ovN].addr = List[addr].addr;
            over[ovN].data = List[addr].data;
            ++ovN;
        }
        else
        {
            negetive[neN].addr = List[addr].addr;
            negetive[neN].data = List[addr].data;
            ++neN;
        }
        addr = List[addr].next;
    }

    Merge(neN, seN, ovN);
    print();

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值