poj 2082 Terrible Sets

Terrible Sets
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4373 Accepted: 2268
Description

Let N be the set of all natural numbers {0 , 1 , 2 , … }, and R be the set of all real numbers. wi, hi for i = 1 … n are some elements in N, and w0 = 0.
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑0<=j<=i-1wj <= x <= ∑0<=j<=iwj}
Again, define set S = {A| A = WH for some W , H ∈ R+ and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}.
Your mission now. What is Max(S)?
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy.
But for this one, believe me, it’s difficult.
Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w1h1+w2h2+…+wnhn < 109.
Output

Simply output Max(S) in a single line for each case.
Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1
Sample Output

12
14

懒得写,粘贴一下题意
题意:题意:有一排靠在一起的矩形,给出它们的高和宽,问它们形成的最大矩形的面积是多少?

题解:将矩形入栈,要保持从栈底到栈顶矩形的高度递增,要入栈矩形高度小于栈顶矩形高度时,就将栈顶矩形出栈。并在出栈过程中记录下出栈矩形能组成的最大矩形面积。然后将出栈矩形与要入栈矩形合并,高度为入栈矩形高度。 所有矩形入栈操作结束后,这时栈内的矩形一定高度递增,最后扫面一遍栈内矩形,记录下最大矩形面积即可。

光看文字题解,可能不是很直观,不容易理解。贴一篇本校师兄的题解,有图片,很清晰:这里写链接内容

#include <cstdio>
#include <stack>
using namespace std;

struct node
{
    int h, w;
};
node no;
int main()
{
    int n;
    while(scanf("%d", &n) != EOF && n != -1)
    {
        stack<node> s;
        int width, lasth = 0, area, ans = 0;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d", &no.w, &no.h);
            if(lasth <= no.h)//后面高的才能压入
            {
                s.push(no);
            }
            else
            {
                width = 0;
                while(!s.empty() && s.top().h > no.h)//判断后面的能不能再压入
                {
                    width += s.top().w;//底边加起来
                    area = (s.top().h * width);//每一个矩形的面积都测一次
                    if(area > ans)//比较一下
                        ans = area;
                    s.pop();
                }
                width += no.w;
                no.w = width;
                s.push(no);
            }
            lasth = no.h;
        }
        width = 0;
        while(!s.empty())
        {
            no = s.top();
            width += no.w;
            area = width * no.h;//每个底都加一下
            if(area > ans)
            {
                ans = area;
            }
            s.pop();
        }
        printf("%d\n", ans);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值