不一样的奇偶性

Description
定义类Integer,包括:
1.一个int类型的属性data。
2. 构造函数。
3. bool judge()方法:求data的各位数字之和,如果这个和是偶数,则返回假,否则返回真。
Input
输入若干个正整数,每个占一行。
Output
每行输入对应一行输出,是对每行输入对应的对象调用judge()方法后输出的结果。
Sample Input
123
456
1
33
Sample Output
NO
YES
YES
NO
HINT
Append Code
append.cc,

int main()
{
    int i;
    while(cin>>i)
    {
        Integer INT(i);
        if (INT.judge())
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}

AC代码

#include <iostream>
 
using namespace std;
class Integer
{
private:
    int data;
public:
    Integer(int d):data(d){}
    bool judge()
    {
        int a[1000];
        int k=0;
        int sum=0;
        while(data>0)
        {
            a[k]=data%10;
            k++;
            data=data/10;
        }
        for(int i=0;i<k;i++)
            sum+=a[i];
        if(sum%2==0) return false;
        else return true;
    }
};
int main()
{
    int i;
    while(cin>>i)
    {
        Integer INT(i);
        if (INT.judge())
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值