POJ--1163 The Triangle

The Triangle
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37088 Accepted: 22209

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30
 
这个题,把三角形用一个0组成的边框套起来就好
 
 
#include <fstream>
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <string>
#include <limits.h>
#include <algorithm>
#include <math.h>
#include <numeric>
#include <functional>
#include <ctype.h>
using namespace std;
int max(int a, int b){
    return a>=b?a:b;
}
int main(){
    int t = 0;
    while(scanf("%d",&t) == 1){//动态分配二位数组空间
        int **sum = new int*[t+1];
        for(int i = 0;i<= t;i++){
            sum[i] = new int[i+2];


            for(int j = 0;j<= i+1;j++){
                sum[i][j] = 0;//初始化 ,不可用memset,成员数量不定
            }
            if(i != 0){
                for(int j = 1;j < i+1; j++){
                    cin>>sum[i][j];//输入每个三角形元素
                }
            }
        }
        int maxvalue = 0;
        for(int i = 1;i <= t; i++){
            for(int j = 1;j < i+1; j++){
                sum[i][j] += max(sum[i-1][j-1],sum[i-1][j]);//状态转移方程
                if(i == t && maxvalue < sum[i][j]){
                    maxvalue = sum[i][j];
                }
            }
        }
        cout<<maxvalue<<endl;
    }


    return 0;
}
 
 
 
 
 
 
 

                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值