1136: 整除的尾数
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 73 Solved: 19
[ Submit][ Status][ BBS]
Description
一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢
Input
输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 1<b<100),若遇到0 0则处理结束
Output
对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。
Sample Input
200 40 1992 95 0 0
Sample Output
00 40 80
15
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
using namespace std;
int arr[105];
int main()
{
int a, b;
int flag;
while (scanf("%d %d", &a, &b) != EOF && a + b)
{
flag = 0;
a = a * 100;
int t = 0;
for(int i = 0; i <= 9; ++i)
{
for(int j = 0; j <= 9; ++j)
{
arr[t++] = i*10 + j;
}
}
for(int i = 0; i < 100; ++i)
{
if((a + arr[i]) % b == 0)
{
if(flag == 0 && arr[i] < 10)
{
flag = 1;
printf("0%d", arr[i]);
}
else if(flag == 0 && arr[i] >= 10)
{
flag = 1;
printf("%d", arr[i]);
}
else if(flag ==1 && arr[i] < 10)
{
printf(" 0%d", arr[i]);
}
else
{
printf(" %d", arr[i]);
}
}
}
printf("\n");
}
return 0;
}