SDJZU_新生_贪心
27:28:20
30:00:00
Current Time: | 2015-01-24 18:58:19 | Contest Type: | Private |
Start Time: | 2015-01-23 15:30:00 | Contest Status: | Running |
End Time: | 2015-01-24 21:30:00 | Manager: | ACboy |
|
|
ID
|
Title
|
---|---|---|---|
19 / 53 | Problem A | 今年暑假不AC | |
2 / 38 | Problem B | Fence Repair | |
18 / 38 | Problem C | FatMouse' Trade | |
9 / 23 | Problem D | Doing Homework again | |
2 / 6 | Problem E | Wooden Sticks | |
Problem F | lines |
nickname改成自己真实姓名
D - Doing Homework again
Crawling in process...
Crawling failed
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
Output
For each test case, you should output the smallest total reduced score, one line per test case.
Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
Sample Output
0 3 5
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct A
{
int time,grade;
}a[1007];
int cmp(A a,A b)
{
if(a.grade==b.grade)
{
return a.time<b.time;
}
return a.grade>b.grade;
}
int main()
{
A a[1007];
int T,i;
scanf("%d",&T);
while(T--)
{
int N,sum=0,b[1007],c,d;
scanf("%d",&N);
for(i=0;i<N;i++)
{
scanf("%d",&a[i].time);
}
for(i=0;i<N;i++)
{
scanf("%d",&a[i].grade);
}
sort(a,a+N,cmp);
memset(b,0,sizeof(b));
for(i=0;i<N;i++)
{
int f;
c=a[i].time;
if(b[c]==0)
{
b[c]=a[i].grade;
}
else
{
for(d=c;d>0;d--)
{
f=0;
if(b[d]==0)
{
f=1;
b[d]=a[i].grade;
break;
}
}
if(f==0)
{
sum+=a[i].grade;
}
}
}
printf("%d\n",sum);
}
return 0;
}
Submit
Problem: | |
Language: | |
Public: |
Rank Setting