【POJ 3281】Dining

【题目】

传送门

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: N, F, and D
Lines 2…N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.


【分析】

大致题意:有 N N N 头牛, F F F 个食物, D D D 个饮料。 N N N 头牛中每头牛都有喜欢的食物和饮料,但是每个食物和饮料只能给一头牛,而且一头牛必须同时获得自己喜欢的一个食物和一个饮料才能满足。问至多有多少头牛可以获得满足。

为了保证食物和饮料都能和牛匹配,我们把牛放在中间,也就是连边的顺序是"食物—牛—饮料"

还有为了保证一头牛只被算一次,我们将牛拆点,然后连一条连容量为 1 1 1 的边

建完边后跑最大流即可

【代码】

#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 10005
#define inf (1ll<<31ll)-1
using namespace std;
int n,f,d,s,t,num=1;
int v[N],w[N],nxt[N],dis[N],fir[N],first[N];
void add(int x,int y,int z)
{
	num++;
	nxt[num]=first[x];
	first[x]=num;
	v[num]=y;
	w[num]=z;
}
bool bfs()
{
	int x,y,i,j;
	memset(dis,-1,sizeof(dis));
	memcpy(fir,first,sizeof(fir));
	queue<int>q;dis[s]=0;q.push(s);
	while(!q.empty())
	{
		x=q.front();
		q.pop();
		for(i=fir[x];i;i=nxt[i])
		{
			y=v[i];
			if(w[i]&&dis[y]==-1)
			{
				dis[y]=dis[x]+1;
				if(y==t)
				  return true;
				q.push(y);
			}
		}
	}
	return false;
}
int dinic(int now,int flow)
{
	if(now==t)  return flow;
	int ans=0,x,delta;
	for(int &i=fir[now];i;i=nxt[i])
	{
		x=v[i];
		if(w[i]&&dis[x]==dis[now]+1)
		{
			delta=dinic(x,min(flow,w[i]));
			w[i]-=delta;w[i^1]+=delta;
			flow-=delta;ans+=delta;
			if(!flow)  return ans;
		}
	}
	return ans;
}
int main()
{
	int i,j,x,fi,di,res=0;
	scanf("%d%d%d",&n,&f,&d);
	s=0,t=2*n+f+d+1;
	for(i=1;i<=f;++i)
	{
		add(s,i,1);
		add(i,s,0);
	}
	for(i=1;i<=n;++i)
	{
		add(f+i,f+n+i,1);
		add(f+n+i,f+i,0);
	}
	for(i=1;i<=n;++i)
	{
		scanf("%d%d",&fi,&di);
		for(j=1;j<=fi;++j)
		{
			scanf("%d",&x);
			add(x,f+i,1);
			add(f+i,x,0);
		}
		for(j=1;j<=di;++j)
		{
			scanf("%d",&x);
			add(f+n+i,f+2*n+x,1);
			add(f+2*n+x,f+n+i,0);
		}
	}
	for(i=1;i<=d;++i)
	{
		add(f+2*n+i,t,1);
		add(t,f+2*n+i,0);
	}
	while(bfs())
	  res+=dinic(s,inf);
	printf("%d",res);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值