hdu-2700-Parity

Parity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5253    Accepted Submission(s): 3932


Problem Description
A bit string has odd parity if the number of 1's is odd. A bit string has even parity if the number of 1's is even.Zero is considered to be an even number, so a bit string with no 1's has even parity. Note that the number of
0's does not affect the parity of a bit string.
 

Input
The input consists of one or more strings, each on a line by itself, followed by a line containing only "#" that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter 'e' or a lowercase letter 'o'.
 

Output
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was 'e') or odd parity (if the letter was 'o').
 

Sample Input
  
  
101e 010010o 1e 000e 110100101o #
 

Sample Output
  
  
1010 0100101 11 0000 1101001010
 
题意:奇偶校验,如果1的个数为偶数结尾是e补零结尾是o补1,,如果1 的个数为奇数反之。
code:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    char a[100];
    int cont;
    while(scanf("%s",a)&&a[0]!='#')
    {
        cont=0;
        int len=strlen(a);
       // printf("")
        for(int i=0;i<len-1;i++){
            if(a[i]=='1')
                cont++;
        }
      //  cout<<cont<<endl;
        if((cont%2==0&&a[len-1]=='e')||(cont%2==1&&a[len-1]=='o'))
                a[len-1]='0';
        else a[len-1]='1';
        printf("%s\n",a);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值